Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53919 - [postfix] Needs grep

Attached to Project: Arch Linux
Opened by Aurélien Ooms (aureooms) - Wednesday, 03 May 2017, 13:15 GMT
Last edited by Gaetan Bisson (vesath) - Wednesday, 03 May 2017, 17:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture x86_64
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Postfix 3.2.0-4 is missing grep dependency.

Additional info:

The omission does not seem to be fatal. Here is the log

> /usr/lib/postfix/bin/postfix-script: line 292: egrep: command not found
> postfix/postfix-script: warning: not owned by postfix: .
> postfix/postfix-script: warning: not owned by postfix: ./pid
> postfix/postfix-script: starting the Postfix mail system

I did not try i686 arch but should be identical.

Steps to reproduce:

1. uninstall grep package
2. install postfix package
3. configure postfix
4. postfix start
This task depends upon

Closed by  Gaetan Bisson (vesath)
Wednesday, 03 May 2017, 17:09 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Wednesday, 03 May 2017, 14:32 GMT
Uninstalling packages in the base group isn't really supported. Many packages will have implicit deps on them; the maintainer can choose to add the dep or leave it out.
Comment by Gaetan Bisson (vesath) - Wednesday, 03 May 2017, 17:09 GMT
Exactly what Doug said. The base group is expected to be installed on *every* Arch system.

Loading...