Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53917 - [gnome-session] assertion failed, gdm doesn't start

Attached to Project: Arch Linux
Opened by Tomi Leppänen (Tomin) - Wednesday, 03 May 2017, 07:18 GMT
Last edited by Jan de Groot (JGC) - Saturday, 06 May 2017, 23:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:


Additional info:
* package version(s)
* gnome-session-3.24.1-1-x86_64.pkg.tar.xz is broken, downgrading to gnome-session-3.22.3-1-x86_64.pkg.tar.xz helps
* config and/or log files etc.
From journalctl:
touko 03 10:10:23 tomin-xps gnome-session-binary[24046]: Entering running state
touko 03 10:10:23 tomin-xps gnome-session[24046]: Unable to init server: Could not connect: Connection refused
touko 03 10:10:23 tomin-xps kernel: gnome-session-f[24065]: segfault at 0 ip 00007f6d28a92db9 sp 00007ffc2227b250 error 4 in libgtk-3.so.0.2200.10[7f6d287b0000+6fb000]
touko 03 10:10:23 tomin-xps systemd[1]: Started Process Core Dump (PID 24066/UID 0).
touko 03 10:10:23 tomin-xps gnome-session[24046]: gnome-session-binary[24046]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
touko 03 10:10:23 tomin-xps gnome-session-binary[24046]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
touko 03 10:10:23 tomin-xps gnome-session[24046]: gnome-session-binary[24046]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
touko 03 10:10:23 tomin-xps gnome-session-binary[24046]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
touko 03 10:10:23 tomin-xps gnome-session[24046]: gnome-session-binary[24046]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
touko 03 10:10:23 tomin-xps gnome-session-binary[24046]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
touko 03 10:10:23 tomin-xps gnome-session-binary[24046]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
touko 03 10:10:23 tomin-xps gnome-session[24046]: gnome-session-binary[24046]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
touko 03 10:10:23 tomin-xps systemd-coredump[24067]: Process 24065 (gnome-session-f) of user 120 dumped core.

Stack trace of thread 24065:
#0 0x00007f6d28a92db9 n/a (libgtk-3.so.0)
#1 0x00007f6d2892ea28 n/a (libgtk-3.so.0)
#2 0x00007f6d28943b24 n/a (libgtk-3.so.0)
#3 0x00007f6d2892fd5c n/a (libgtk-3.so.0)
#4 0x00007f6d28943a4c n/a (libgtk-3.so.0)
#5 0x00007f6d28943aa5 n/a (libgtk-3.so.0)
#6 0x00007f6d289306c2 n/a (libgtk-3.so.0)
#7 0x00007f6d2829b30f g_type_create_instance (libgobject-2.0.so.0)
#8 0x00007f6d2827d1fb n/a (libgobject-2.0.so.0)
#9 0x00007f6d2827ec0d g_object_newv (libgobject-2.0.so.0)
#10 0x00007f6d2827f3c4 g_object_new (libgobject-2.0.so.0)
#11 0x00007f6d2894bf8a n/a (libgtk-3.so.0)
#12 0x00007f6d28b29e77 n/a (libgtk-3.so.0)
#13 0x00007f6d2829b30f g_type_create_instance (libgobject-2.0.so.0)
#14 0x00007f6d2827d1fb n/a (libgobject-2.0.so.0)
#15 0x00007f6d2827ec0d g_object_newv (libgobject-2.0.so.0)
#16 0x00007f6d2827f3c4 g_object_new (libgobject-2.0.so.0)
#17 0x0000000000401db3 n/a (gnome-session-failed)
#18 0x00007f6d27bd1511 __libc_start_main (libc.so.6)
#19 0x00000000004021ba n/a (gnome-session-failed)
touko 03 10:10:24 tomin-xps gdm[23765]: GdmDisplay: display lasted 0,973975 seconds
touko 03 10:10:24 tomin-xps gdm[23765]: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors
touko 03 10:10:24 tomin-xps gdm[23765]: Child process -24036 was already dead.
touko 03 10:10:24 tomin-xps systemd-logind[573]: Removed session c49.

Steps to reproduce:
1. Upgrade to latest packages (especially gnome-session-3.24.1-1-x86_64.pkg.tar.xz).
2. Restart gdm.
3. gdm doesn't start.
This task depends upon

Closed by  Jan de Groot (JGC)
Saturday, 06 May 2017, 23:42 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Wednesday, 03 May 2017, 08:11 GMT
Can you provide more logs? Looks like X or Wayland fails to start and gnome-session/gtk3 not handling the failure correctly.
Comment by Tomi Leppänen (Tomin) - Wednesday, 03 May 2017, 08:15 GMT
Yes, I can, but I would like to know what. Probably not just all "journalctl --boot --system" output.
Comment by Jan de Groot (JGC) - Wednesday, 03 May 2017, 14:34 GMT
There's probably more log before the gnome-session crash log that could be useful.
Comment by Tomi Leppänen (Tomin) - Wednesday, 03 May 2017, 15:19 GMT
Well, here is probably everything from "journalctl --boot --system" that is relevant for this bug report. Please ask, if there is something else I should provide.
Comment by Jan de Groot (JGC) - Wednesday, 03 May 2017, 21:33 GMT
Looking at your logs it seems gnome-settings-daemon is not working or not installed. Tbe segfault is from the gnome-session-failed binary that seems to be broken but nobody cares about it.
Comment by Jan de Groot (JGC) - Friday, 05 May 2017, 22:13 GMT
  • Field changed: Status (Unconfirmed → Waiting on Response)
Your bug is caused by having an outdated version of gnome-settings-daemon installed (or no gnome-settings-daemon at all). gnome-session 3.24.x needs the new plugin/daemon layout introduced by 3.23.x and higher.
Comment by Tomi Leppänen (Tomin) - Saturday, 06 May 2017, 08:23 GMT
You are right. This was my mistake. I had patched version of gnome-settings-daemon installed for redshift, which I totally forgot, and that caused the problem. It's now working and this bug is invalid. Thank you!

Loading...