Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53915 - [mpv] mpv no longer compiles with libdvdnav support by default / dvd playback segfault

Attached to Project: Community Packages
Opened by Mittens (mittens2001) - Wednesday, 03 May 2017, 02:45 GMT
Last edited by Christian Hesse (eworm) - Saturday, 06 May 2017, 18:39 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
According to the Github changelog, version 0.25.0 of mpv no longer compiles with libdvdnav support by default . Preferably the packaging would use the --enable-dvdnav flag during build() to continue DVD playback support, however if the packagers decide to not enable this functionality libdvdnav should be removed from the dependencies. I believe that trying to run "mpv dvd://"; will result in a segfault currently (this may be fixed upstream).

Additional info:
* version 1:0.25.0-1

Steps to reproduce:
Compile mpv with default settings and attempt to play "dvd://".
This task depends upon

Closed by  Christian Hesse (eworm)
Saturday, 06 May 2017, 18:39 GMT
Reason for closing:  Implemented
Additional comments about closing:  mpv 1:0.25.0-2
Comment by Johannes Truschnigg (colo) - Saturday, 06 May 2017, 14:21 GMT
With how mpv is currently configured and built, trying to play back a DVD (even with no disk or even drive present) results in a segfault. This is due to https://github.com/mpv-player/mpv/commit/24f568c06858146681decb1d4be50ef68865d136 not being in the 0.25 release.

I'd very much appreciate for proper DVD support to return to arch's mpv packages.

Loading...