Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53890 - [firefox/thunderbird] cargo 0.18 breaks build

Attached to Project: Arch Linux
Opened by Turbo B (Turbo) - Sunday, 30 April 2017, 14:56 GMT
Last edited by Jan Alexander Steffens (heftig) - Sunday, 30 April 2017, 19:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Urgent
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I use to build FF on my machine because i want to enable jack. It was working well for previous version but this time i get this error:

error[E0463]: can't find crate for `cheddar`
--> /PKG/FireFox53/src/mozilla-unified/media/libstagefright/binding/mp4parse_capi/build.rs:1:1
|
1 | extern crate cheddar;
| ^^^^^^^^^^^^^^^^^^^^^ can't find crate

error: aborting due to previous error

error: Could not compile `mp4parse_capi`.

Caused by:
process didn't exit successfully: `/usr/bin/rustc --crate-name build_script_build /PKG/FireFox53/src/mozilla-unified/media/libstagefright/binding/mp4parse_capi/build.rs --crate-type bin --emit=dep-info,link -C opt-level=2 -C codegen-units=1 -C debuginfo=2 -C metadata=1c1f62a8a373eee8 -C extra-filename=-1c1f62a8a373eee8 --out-dir /PKG/FireFox53/src/mozilla-unified/obj-x86_64-pc-linux-gnu/toolkit/library/gtest/rust/./release/build/mp4parse_capi-1c1f62a8a373eee8 -L dependency=/home/turbo/PKG/FireFox53/src/mozilla-unified/obj-x86_64-pc-linux-gnu/toolkit/library/gtest/rust/./release/deps` (exit code: 101)
Build failed, waiting for other jobs to finish...



Additional info:
* Fire Fox 53.0-2

This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Sunday, 30 April 2017, 19:52 GMT
Reason for closing:  Fixed
Comment by Jan Alexander Steffens (heftig) - Sunday, 30 April 2017, 18:35 GMT
Thunderbird now fails the same way. I guess this is a rust 1.17 / cargo 0.18 issue.
Comment by Jan Alexander Steffens (heftig) - Sunday, 30 April 2017, 18:45 GMT
Seems this is a known issue... https://bugzilla.mozilla.org/show_bug.cgi?id=1338655

Trying a patch.
Comment by Jan Alexander Steffens (heftig) - Sunday, 30 April 2017, 19:51 GMT
Thunderbird 52.1.0-1 now ships with a patch.
Firefox has had a patch added in trunk: https://git.archlinux.org/svntogit/packages.git/log/trunk?h=packages/firefox

Loading...