Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53867 - [boinc-nox] Missing dependency on libxss stops boinc_client

Attached to Project: Community Packages
Opened by k2_8191 (k2_8191) - Friday, 28 April 2017, 11:21 GMT
Last edited by Balló György (City-busz) - Monday, 19 June 2017, 18:58 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After upgrading boinc-nox from 7.6.33-1 to 7.6.33-2, boinc_client start requiring libXss.so.1.
I checked the journal via journalctl and found below:
Apr 28 19:40:54 myboincserver boinc_client[396]: /usr/bin/boinc_client: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory

I believe the dependency setting of boinc_nox package needs to be updated or more likely we need to remove the dependency (since this is nox package).

Steps to reproduce:
1. Install boinc_nox-7.6.33-2
2. Start boinc.service by systemctl
This task depends upon

Closed by  Balló György (City-busz)
Monday, 19 June 2017, 18:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  boinc 7.6.33-4
Comment by Antonio Rojas (arojas) - Friday, 28 April 2017, 20:42 GMT
Wow, this is a weird one. I've rebuilt it a few times and it seems to link to libxss randomly about 50% of the times. There must be a race condition somewhere, but I can't figure out where.
Anyway, uploaded one of the good builds. I'll leave this open in case Felix wants to investigate further, because this will probably happen again in the future.
Comment by k2_8191 (k2_8191) - Thursday, 25 May 2017, 12:32 GMT
I finally got time to test boinc_nox-7.6.33-3 in my server and confirmed this version doesn't have the problem.
Thank you for rebuilding!

Loading...