Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53861 - Elasticsearch fails to start

Attached to Project: Community Packages
Opened by Matthew Haffner (haffnasty) - Thursday, 27 April 2017, 22:54 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 27 April 2017, 23:12 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Elasticsearch fails to start


Additional info:
* Version: 5.3.1, Build: 5f9cf58/2017-04-17T15:52:53.846Z, JVM: 1.8.0_121
* Default config file


Steps to reproduce:

pacman -Syu
systemctl start elasticsearch

Initially, from systemctl status elasticsearch I get:

$ systemctl status elasticsearch
● elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
Active: activating (auto-restart) (Result: exit-code) since Thu 2017-04-27 17:48:12 CDT; 119ms ago
Docs: http://www.elastic.co
Process: 3072 ExecStart=/usr/bin/elasticsearch -d -p /run/elasticsearch/elasticsearch.pid -E default.path.home=${ES_HOME} -E default.path.logs=${LOG_DIR} -E default.path.data=${DATA_DIR} -E default.path.conf=${CONF_DIR} (code=exited, status=0/SUCCESS)
Main PID: 3101 (code=exited, status=1/FAILURE)

Apr 27 17:48:12 panopticon systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
Apr 27 17:48:12 panopticon systemd[1]: elasticsearch.service: Unit entered failed state.
Apr 27 17:48:12 panopticon systemd[1]: elasticsearch.service: Failed with result 'exit-code'.
Apr 27 17:48:12 panopticon systemd[1]: elasticsearch.service: Service hold-off time over, scheduling restart.
Apr 27 17:48:12 panopticon systemd[1]: Stopped Elasticsearch.
Apr 27 17:48:12 panopticon systemd[1]: Starting Elasticsearch...

After a couple seconds I get:
$ systemctl status elasticsearch
● elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Thu 2017-04-27 17:48:16 CDT; 5s ago
Docs: http://www.elastic.co
Process: 3255 ExecStart=/usr/bin/elasticsearch -d -p /run/elasticsearch/elasticsearch.pid -E default.path.home=${ES_HOME} -E default.path.logs=${LOG_DIR} -E default.path.data=${DATA_DIR} -E default.path.conf=${CONF_DIR} (code=exited, status=0/SUCCESS)
Main PID: 3284 (code=exited, status=1/FAILURE)

Apr 27 17:48:16 panopticon systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
Apr 27 17:48:16 panopticon systemd[1]: elasticsearch.service: Unit entered failed state.
Apr 27 17:48:16 panopticon systemd[1]: elasticsearch.service: Failed with result 'exit-code'.
Apr 27 17:48:16 panopticon systemd[1]: elasticsearch.service: Service hold-off time over, scheduling restart.
Apr 27 17:48:16 panopticon systemd[1]: Stopped Elasticsearch.
Apr 27 17:48:16 panopticon systemd[1]: elasticsearch.service: Start request repeated too quickly.
Apr 27 17:48:16 panopticon systemd[1]: Failed to start Elasticsearch.
Apr 27 17:48:16 panopticon systemd[1]: elasticsearch.service: Unit entered failed state.
Apr 27 17:48:16 panopticon systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

I've had this issue on two machines after updating my systems. For both, rebooting fixed the issue, but I think this was a temporary fix. As of today, I cannot get Elasticsearch on one of the machines to work. I've also tried un/reinstalling:

pacman -R elasticsearch
pacman -S elasticsearch
systemctl enable elasticsearch.service
systemctl start elasticsearch.service

Same result. I have noticed that /run/elasticsearch does not exist and neither does /var/run/elasticsearch on the non-working machine.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 27 April 2017, 23:12 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Thursday, 27 April 2017, 23:12 GMT
/var/run is a symlink to /run, so your "non-working" machine is likely screwed up. If a reboot fixed it, it's likely something else just needed restarted. Nothing much we can do.

Loading...