Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53779 - [qemu] [qemu-headless] error while loading shared libraries: libssl.so.1.0.0

Attached to Project: Arch Linux
Opened by Curtis Lee Bolin (curtisleebolin) - Monday, 24 April 2017, 13:39 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 24 April 2017, 14:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
qemu seems to depend on extra/openssl-1.0, but it isn't being installed as a dependency.

Error starting domain: internal error: process exited while connecting to monitor: /usr/sbin/qemu-system-x86_64: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

No error after installing extra/openssl-1.0 .

Additional info:
qemu 2.8.1-1
qemu-headless 2.8.1-1

Steps to reproduce:
Try to start qemu after updating.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 24 April 2017, 14:30 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Monday, 24 April 2017, 13:49 GMT
qemu is not linked to libssl at all. What do you have that is?
Comment by Curtis Lee Bolin (curtisleebolin) - Monday, 24 April 2017, 14:09 GMT
$ ldd /usr/bin/qemu-system-x86_64 | grep libssl
libssl.so.1.0.0 => /usr/lib/libssl.so.1.0.0 (0x00007f556ceb2000)

$ pkgfile /usr/bin/qemu-system-x86_64
extra/qemu
extra/qemu-headless
Comment by Naoki Kawakami (aya) - Monday, 24 April 2017, 14:13 GMT
# pacman -S openssl-1.0

should fix you
But honestly, there should have been announced on the top page because so many things broke with openssl update.
Comment by Curtis Lee Bolin (curtisleebolin) - Monday, 24 April 2017, 14:15 GMT
Naoki, I stated, "No error after installing extra/openssl-1.0".
Comment by David Thurstenson (thurstylark) - Monday, 24 April 2017, 14:17 GMT
Why should there be an announcement for something that doesn't break if you're avoiding partial upgrades and using a mirror that is up to date?
Comment by Doug Newgard (Scimmia) - Monday, 24 April 2017, 14:18 GMT
ldd us useless here, it's recursive. Use lddtree from pax-utils.
Comment by Doug Newgard (Scimmia) - Monday, 24 April 2017, 14:18 GMT
aya, stop posting bad info in every ticket.
Comment by Curtis Lee Bolin (curtisleebolin) - Monday, 24 April 2017, 14:27 GMT
Doug, thanks for the tip. So libspice-server.so.1 is depending on libssl.so.1.0.0 . So that would make the package depending on extra/openssl-1.0, extra/spice.

Please change the bug to package extra/spice.

Thanks again, Doug.
Comment by Doug Newgard (Scimmia) - Monday, 24 April 2017, 14:29 GMT
Except spice 0.12.8-2 is already linked to libssl.so.1.1. Partial update/mirror issue.

Loading...