Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53737 - [virtualbox-ext-vnc] VBoxManage asks for license agreement

Attached to Project: Community Packages
Opened by Hartmut Malzahn (hwm) - Friday, 21 April 2017, 09:52 GMT
Last edited by Christian Hesse (eworm) - Saturday, 29 April 2017, 23:03 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Hesse (eworm)
Sébastien Luttringer (seblu)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

upgrading this package does not work, VBoxManage asks for confirmation of the license

Additional info:
* package version(s)
* config and/or log files etc.

ver. 5.1.20

Steps to reproduce:
pacman -Suy (or just pacman -S virtualbox-ext-vnc) gives "error: command failed to execute correctly"

sudo VBoxManage extpack install /usr/share/virtualbox/extensions/VNC-5.1.20.vbox-extpack works, and states

For batch installaltion add
--accept-license=ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6
to the VBoxManage command line.
This task depends upon

Closed by  Christian Hesse (eworm)
Saturday, 29 April 2017, 23:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  virtualbox 5.1.22
Comment by Christian Hesse (eworm) - Sunday, 23 April 2017, 19:54 GMT
Virtualbox including the VNC extension is released under GNU GPL, the license file is shipped in the package.
So we should be fine to suppress the manual license agreement by adding the --accept-license switch, no? If anybody has concerns... Please step up.
Comment by eugene (Just-a-Punk) - Monday, 24 April 2017, 06:09 GMT
-----SOLVED-----
Hi, I have the same problem.
(I'll translate my Cyrillic locale)
-----
$ sudo pacman -S virtualbox-ext-vnc
предупреждение (caution!): virtualbox-ext-vnc-5.1.20-1 не устарел (not outdated) -- переустанавливается (reinstallin')
разрешение зависимостей... (Dependency resolution ...)
проверка конфликтов... (Conflict checking ...)
Пакет\Packet (1) Старая версия\Old vers. Новая версия\New vers. Изменение размера\Space will change

community/virtualbox-ext-vnc 5.1.20-1 5.1.20-1 0,00 MiB

Будет установлено\will be installed: 0,08 MiB
Изменение размера\Space will change: 0,00 MiB

:: Приступить к установке? \ Install? [Y/n] y
(1/1) проверка ключей\ Keys checking [######################################################################] 100%
(1/1) проверяется целостность пакета \ checks the integrity of the packet [######################################################################] 100%
(1/1) загрузка файлов пакетов \ Downloading package files [######################################################################] 100%
(1/1) проверка конфликтов файлов \ Checking for file conflicts [######################################################################] 100%
(1/1) проверяется доступное место \ Checking available space [######################################################################] 100%
:: Processing package changes...
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
(1/1) переустановка virtualbox-ext-vnc [######################################################################] 100%
ошибка: не удалось корректно выполнить команду \\\ "error: command failed to execute correctly"
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
-----

-------THANKS! I THINK SOLVED-----
$ sudo VBoxManage extpack install /usr/share/virtualbox/extensions/VNC-5.1.20.vbox-extpack --accept-license=ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6
License accepted.
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Successfully installed "VNC".
Comment by morealaz (morealaz) - Wednesday, 26 April 2017, 02:28 GMT
according to comment from @jamesan in virtualbox-ext-oracle page in AUR (https://aur.archlinux.org/packages/virtualbox-ext-oracle/):
It needs to add following command to virtualbox-ext-vnc.install file post-install function:
post_install () {
VBoxManage extpack install --accept-license=$(sha256sum /usr/share/licenses/virtualbox-ext-vnc/LICENSE | head --bytes=64) "/usr/share/virtualbox/extensions/VNC-${1%%-*}.vbox-extpack" >/dev/null
}
Comment by Christian Hesse (eworm) - Wednesday, 26 April 2017, 19:38 GMT
I know how to do this technically.
The question is: Are we allowed to do this without breaking licensing stuff?

Loading...