Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53729 - [qtkeychain] rfe: enable libsecret instead of deprecated libgnome-keyring

Attached to Project: Community Packages
Opened by larchunix (larchunix) - Thursday, 20 April 2017, 20:37 GMT
Last edited by Antonio Rojas (arojas) - Friday, 13 July 2018, 14:21 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

Support for libsecret has been introduced in version 0.8.0.

As libgnome-keyring is deprecated in favor of libsecret [1], would it be possible to switch from libgnome-keyring to libsecret ?

This can be achieved by adding libsecret to makedepends array and by replacing libgnome-keyring by libsecret in optdepends array.

Regards,

[1]: https://wiki.gnome.org/Projects/Libsecret
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 13 July 2018, 14:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  reenabled in 0.9.0
Comment by Antonio Rojas (arojas) - Thursday, 20 April 2017, 22:17 GMT
libsecret is already a makedepens as it is pulled by kwallet, so the current version should support it. (EDIT: it's pulled by pacman actually)
Comment by larchunix (larchunix) - Friday, 21 April 2017, 17:07 GMT
My bad, you are right. I removed libgnome-keyring and owncloud client still finds my credentials.

Modifying optional dependencies is sufficient.
Comment by Antonio Rojas (arojas) - Friday, 21 April 2017, 18:20 GMT
Unfortunately I've had to disable libsecret because it breaks the kwallet backend, which is a serious regression. Will re-enable it when the issue is fixed upstream
Comment by larchunix (larchunix) - Friday, 21 April 2017, 19:56 GMT
That's sad. For now I will rebuild it locally with libsecret support because I don't use use kwallet.

Thanks for your support !

P.S: I guess you made a mistake with your last update. Although you added the flag -DLIBSECRET_SUPPORT=OFF for cmake, you also added libsecret as an optional dependency.

Loading...