AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#53673 - "Required By" fails with invalid "Provides" variable

Attached to Project: AUR web interface
Opened by Janne Heß (das_j) - Friday, 14 April 2017, 21:36 GMT
Last edited by Lukas Fleischer (lfleischer) - Saturday, 11 November 2017, 19:35 GMT
Task Type Bug Report
Category PKGBUILD Parser
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 4.4.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When having an invalid character in the "Provides" field in the PKGBUILD, all packages in the AUR depend on it.

Example: https://aur.archlinux.org/packages/menu-calc-git/

This should either not happen (no packages should "depend" on it), or the hook should decline the package.
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Saturday, 11 November 2017, 19:35 GMT
Reason for closing:  Works for me
Comment by Lukas Fleischer (lfleischer) - Sunday, 05 November 2017, 18:46 GMT
The package seems to be gone. Do you remember what exactly the provides field looked like?
Comment by Janne Heß (das_j) - Monday, 06 November 2017, 06:15 GMT
I think it was just '='
Comment by Lukas Fleischer (lfleischer) - Tuesday, 07 November 2017, 08:03 GMT
Strange, I restored the package but it seems like it is no longer possible to reproduce this bug...

Loading...