Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53669 - [dkms] Build order is random

Attached to Project: Arch Linux
Opened by Janne Heß (das_j) - Friday, 14 April 2017, 16:11 GMT
Last edited by Sébastien Luttringer (seblu) - Saturday, 08 July 2017, 14:50 GMT
Task Type General Gripe
Category Packages: Extra
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

I need to build both SPL and ZFS with DKMS.
ZFS depends on the built SPL module.
The order of execution seems random. Sometimes, SPL is built first (everything good), or ZFS is built first and lacks SPL.

The order of the build should be predictable (alphabetically).

I wrote a (probably ugly) patch for the alpm-hook which replaces the map with an array and orders the array (attached).


Additional info:
* package version(s)

dkms 2.3-2

* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Saturday, 08 July 2017, 14:50 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#52901
Comment by Sébastien Luttringer (seblu) - Saturday, 08 July 2017, 14:43 GMT
If the module B has to be built before module A. What you are proposing will not help, as you cannot change the module name in configuration in order to define the correct build order.
This is relevant only because SPL is before ZFS alphabetically and the dependency is in the same direction.

Loading...