Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53497 - [linux] Unable to start X with 4.10 kernel

Attached to Project: Arch Linux
Opened by Daurnimator (daurnimator) - Wednesday, 29 March 2017, 02:59 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 01 March 2022, 21:16 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I since 4.10 I've been unable to boot into X.
Downgraded to 4.9 series for now.

In logs I see:

Mar 29 13:25:44 daurn-m73 kernel: fbcon: inteldrmfb (fb0) is primary device
Mar 29 13:25:44 daurn-m73 kernel: Console: switching to colour frame buffer device 480x135
Mar 29 13:25:44 daurn-m73 kernel: snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC662 rev3: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
Mar 29 13:25:44 daurn-m73 kernel: snd_hda_codec_realtek hdaudioC1D0: speaker_outs=1 (0x15/0x0/0x0/0x0/0x0)
Mar 29 13:25:44 daurn-m73 kernel: snd_hda_codec_realtek hdaudioC1D0: hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
Mar 29 13:25:44 daurn-m73 kernel: snd_hda_codec_realtek hdaudioC1D0: mono: mono_out=0x0
Mar 29 13:25:44 daurn-m73 kernel: snd_hda_codec_realtek hdaudioC1D0: inputs:
Mar 29 13:25:44 daurn-m73 kernel: snd_hda_codec_realtek hdaudioC1D0: Front Mic=0x19
Mar 29 13:25:44 daurn-m73 kernel: snd_hda_codec_realtek hdaudioC1D0: Rear Mic=0x18
Mar 29 13:25:44 daurn-m73 kernel: snd_hda_codec_realtek hdaudioC1D0: Line=0x1a
Mar 29 13:25:44 daurn-m73 kernel: input: HDA Intel PCH Front Mic as /devices/pci0000:00/0000:00:1b.0/sound/card1/input12
Mar 29 13:25:44 daurn-m73 kernel: input: HDA Intel PCH Rear Mic as /devices/pci0000:00/0000:00:1b.0/sound/card1/input13
Mar 29 13:25:44 daurn-m73 kernel: input: HDA Intel PCH Line as /devices/pci0000:00/0000:00:1b.0/sound/card1/input14
Mar 29 13:25:44 daurn-m73 kernel: input: HDA Intel PCH Line Out as /devices/pci0000:00/0000:00:1b.0/sound/card1/input15
Mar 29 13:25:44 daurn-m73 kernel: input: HDA Intel PCH Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card1/input16
Mar 29 13:25:44 daurn-m73 kernel: i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Mar 29 13:25:44 daurn-m73 kernel: input: HDA Intel HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card0/input17
Mar 29 13:25:44 daurn-m73 kernel: input: HDA Intel HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card0/input18
Mar 29 13:25:44 daurn-m73 kernel: nouveau 0000:01:00.0: enabling device (0000 -> 0003)
Mar 29 13:25:44 daurn-m73 kernel: nouveau 0000:01:00.0: NVIDIA GT218 (0a8280b1)
Mar 29 13:25:44 daurn-m73 kernel: nouveau 0000:01:00.0: bios: version 70.18.64.00.49
Mar 29 13:25:44 daurn-m73 kernel: nouveau 0000:01:00.0: bios: OOB 1 01452301 01452301
Mar 29 13:25:44 daurn-m73 kernel: nouveau 0000:01:00.0: bios: OOB 1 2223b792 2223b792
Mar 29 13:25:44 daurn-m73 kernel: nouveau 0000:01:00.0: bios: OOB 1 2223b792 2223b792
Mar 29 13:25:44 daurn-m73 kernel: nouveau 0000:01:00.0: bios: OOB 1 2223b792 2223b792

Then later:

Mar 29 13:28:17 daurn-m73 kernel: INFO: task kworker/3:1:47 blocked for more than 120 seconds.
Mar 29 13:28:17 daurn-m73 kernel: Tainted: G O 4.10.6-1-ARCH #1
Mar 29 13:28:17 daurn-m73 kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Mar 29 13:28:17 daurn-m73 kernel: kworker/3:1 D 0 47 2 0x00000000
Mar 29 13:28:17 daurn-m73 kernel: Workqueue: events output_poll_execute [drm_kms_helper]
Mar 29 13:28:17 daurn-m73 kernel: Call Trace:
Mar 29 13:28:17 daurn-m73 kernel: __schedule+0x22f/0x700
Mar 29 13:28:17 daurn-m73 kernel: schedule+0x3d/0x90
Mar 29 13:28:17 daurn-m73 kernel: rpm_resume+0x118/0x6f0
Mar 29 13:28:17 daurn-m73 kernel: ? wake_atomic_t_function+0x60/0x60
Mar 29 13:28:17 daurn-m73 kernel: __pm_runtime_resume+0x3f/0x60
Mar 29 13:28:17 daurn-m73 kernel: nouveau_connector_detect+0x70/0x520 [nouveau]
Mar 29 13:28:17 daurn-m73 kernel: ? put_prev_entity+0x33/0xa10
Mar 29 13:28:17 daurn-m73 kernel: ? pick_next_task_fair+0x138/0x4c0
Mar 29 13:28:17 daurn-m73 kernel: output_poll_execute+0xc2/0x250 [drm_kms_helper]
Mar 29 13:28:17 daurn-m73 kernel: process_one_work+0x1e5/0x470
Mar 29 13:28:17 daurn-m73 kernel: worker_thread+0x48/0x4e0
Mar 29 13:28:17 daurn-m73 kernel: kthread+0x101/0x140
Mar 29 13:28:17 daurn-m73 kernel: ? process_one_work+0x470/0x470
Mar 29 13:28:17 daurn-m73 kernel: ? kthread_create_on_node+0x60/0x60
Mar 29 13:28:17 daurn-m73 kernel: ret_from_fork+0x2c/0x40
Mar 29 13:28:17 daurn-m73 kernel: INFO: task kworker/3:2:292 blocked for more than 120 seconds.
Mar 29 13:28:17 daurn-m73 kernel: Tainted: G O 4.10.6-1-ARCH #1
Mar 29 13:28:17 daurn-m73 kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Mar 29 13:28:17 daurn-m73 kernel: kworker/3:2 D 0 292 2 0x00000000
Mar 29 13:28:17 daurn-m73 kernel: Workqueue: pm pm_runtime_work
Mar 29 13:28:17 daurn-m73 kernel: Call Trace:
Mar 29 13:28:17 daurn-m73 kernel: __schedule+0x22f/0x700
Mar 29 13:28:17 daurn-m73 kernel: schedule+0x3d/0x90
Mar 29 13:28:17 daurn-m73 kernel: rpm_resume+0x118/0x6f0
Mar 29 13:28:17 daurn-m73 kernel: ? wake_atomic_t_function+0x60/0x60
Mar 29 13:28:17 daurn-m73 kernel: ? pci_pm_runtime_resume+0xa0/0xa0
Mar 29 13:28:17 daurn-m73 kernel: pm_runtime_forbid+0x4c/0x60
Mar 29 13:28:17 daurn-m73 kernel: nouveau_pmops_runtime_suspend+0xcc/0xd0 [nouveau]
Mar 29 13:28:17 daurn-m73 kernel: pci_pm_runtime_suspend+0x55/0x180
Mar 29 13:28:17 daurn-m73 kernel: ? pci_pm_runtime_resume+0xa0/0xa0
Mar 29 13:28:17 daurn-m73 kernel: __rpm_callback+0xb9/0x1f0
Mar 29 13:28:17 daurn-m73 kernel: rpm_callback+0x24/0x80
Mar 29 13:28:17 daurn-m73 kernel: ? pci_pm_runtime_resume+0xa0/0xa0
Mar 29 13:28:17 daurn-m73 kernel: rpm_suspend+0x132/0x690
Mar 29 13:28:17 daurn-m73 kernel: ? finish_task_switch+0x78/0x200
Mar 29 13:28:17 daurn-m73 kernel: pm_runtime_work+0x6f/0xb0
Mar 29 13:28:17 daurn-m73 kernel: process_one_work+0x1e5/0x470
Mar 29 13:28:17 daurn-m73 kernel: worker_thread+0x48/0x4e0
Mar 29 13:28:17 daurn-m73 kernel: kthread+0x101/0x140
Mar 29 13:28:17 daurn-m73 kernel: ? process_one_work+0x470/0x470
Mar 29 13:28:17 daurn-m73 kernel: ? kthread_create_on_node+0x60/0x60
Mar 29 13:28:17 daurn-m73 kernel: ret_from_fork+0x2c/0x40
Mar 29 13:28:17 daurn-m73 kernel: INFO: task Xorg.wrap:636 blocked for more than 120 seconds.
Mar 29 13:28:17 daurn-m73 kernel: Tainted: G O 4.10.6-1-ARCH #1
Mar 29 13:28:17 daurn-m73 kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Mar 29 13:28:17 daurn-m73 kernel: Xorg.wrap D 0 636 633 0x00000004
Mar 29 13:28:17 daurn-m73 kernel: Call Trace:
Mar 29 13:28:17 daurn-m73 kernel: __schedule+0x22f/0x700
Mar 29 13:28:17 daurn-m73 kernel: schedule+0x3d/0x90
Mar 29 13:28:17 daurn-m73 kernel: rpm_resume+0x118/0x6f0
Mar 29 13:28:17 daurn-m73 kernel: ? wake_atomic_t_function+0x60/0x60
Mar 29 13:28:17 daurn-m73 kernel: __pm_runtime_resume+0x3f/0x60
Mar 29 13:28:17 daurn-m73 kernel: nouveau_drm_open+0x3d/0x280 [nouveau]
Mar 29 13:28:17 daurn-m73 kernel: ? security_capable+0x48/0x60
Mar 29 13:28:17 daurn-m73 kernel: drm_open+0x21c/0x420 [drm]
Mar 29 13:28:17 daurn-m73 kernel: drm_stub_open+0xbb/0xf0 [drm]
Mar 29 13:28:17 daurn-m73 kernel: chrdev_open+0xb0/0x1e0
Mar 29 13:28:17 daurn-m73 kernel: do_dentry_open+0x20a/0x2f0
Mar 29 13:28:17 daurn-m73 kernel: ? cdev_put+0x30/0x30
Mar 29 13:28:17 daurn-m73 kernel: vfs_open+0x4c/0x70
Mar 29 13:28:17 daurn-m73 kernel: ? may_open+0x9b/0x100
Mar 29 13:28:17 daurn-m73 kernel: path_openat+0x2b2/0x1180
Mar 29 13:28:17 daurn-m73 kernel: ? __drm_atomic_state_free+0x5b/0x60 [drm]
Mar 29 13:28:17 daurn-m73 kernel: ? __intel_fb_obj_invalidate+0x43/0x80 [i915]
Mar 29 13:28:17 daurn-m73 kernel: do_filp_open+0x91/0x100
Mar 29 13:28:17 daurn-m73 kernel: ? __alloc_fd+0xb2/0x160
Mar 29 13:28:17 daurn-m73 kernel: do_sys_open+0x147/0x210
Mar 29 13:28:17 daurn-m73 kernel: SyS_open+0x1e/0x20
Mar 29 13:28:17 daurn-m73 kernel: entry_SYSCALL_64_fastpath+0x1a/0xa9
Mar 29 13:28:17 daurn-m73 kernel: RIP: 0033:0x7fb749755610
Mar 29 13:28:17 daurn-m73 kernel: RSP: 002b:00007ffc4e6048c8 EFLAGS: 00000246 ORIG_RAX: 0000000000000002
Mar 29 13:28:17 daurn-m73 kernel: RAX: ffffffffffffffda RBX: 00007ffc4e6049d0 RCX: 00007fb749755610
Mar 29 13:28:17 daurn-m73 kernel: RDX: 0000000000000000 RSI: 0000000000000002 RDI: 00007ffc4e6049d0
Mar 29 13:28:17 daurn-m73 kernel: RBP: 0000000000000000 R08: 00000000ffffffff R09: 000000000000000e
Mar 29 13:28:17 daurn-m73 kernel: R10: 0000000000000000 R11: 0000000000000246 R12: 00007ffc4e6048f0
Mar 29 13:28:17 daurn-m73 kernel: R13: 0000000000000001 R14: 0000000000000001 R15: 0000000000000003


Downgraded to 4.9 for now.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 01 March 2022, 21:16 GMT
Reason for closing:  None
Comment by Daurnimator (daurnimator) - Wednesday, 29 March 2017, 03:01 GMT
Possibly related to https://bbs.archlinux.org/viewtopic.php?id=223588 (https://bugs.freedesktop.org/show_bug.cgi?id=98690)
Comment by Daurnimator (daurnimator) - Wednesday, 29 March 2017, 03:06 GMT Comment by Daurnimator (daurnimator) - Wednesday, 29 March 2017, 03:13 GMT
Seems to be in the nouveau driver somewhere.
I've blacklisted that driver for now (as I don't use the nVidia card in this PC at all) and upgraded to 4.10 again.
Comment by mattia (nTia89) - Sunday, 27 February 2022, 14:21 GMT
I cannot reproduce the issue. Is it still valid?
Comment by Daurnimator (daurnimator) - Tuesday, 01 March 2022, 07:40 GMT
I no longer have the relevant hardware; so I'll close this bug for now.,

Loading...