Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53478 - [octave] upon normal exit GUI closes with " panic: Aborted -- stopping myself..."

Attached to Project: Community Packages
Opened by Roelof Rietbroek (Strawpants) - Tuesday, 28 March 2017, 06:16 GMT
Last edited by Antonio Rojas (arojas) - Friday, 08 September 2017, 11:21 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
When typing 'exit' or 'quit' in the GUI, octave closes with:
>
panic: Aborted -- stopping myself...
attempting to save variables to 'octave-workspace'...
panic: attempted clean up failed -- aborting...
octave exited with signal 6
<
Steps to reproduce:
1 from a shell start: octave
2 type exit or quit in gui

This does not happen when octave-cli is used. But it is somewhat annoying as it leaves (empty) octave-workspace files around.

Might be an upstream bug but I also found another arch user having the same problem:
http://stackoverflow.com/questions/42461527/octave-dumps-core-on-exit

Additional info:
* Octave version 4.2.1-4

This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 08 September 2017, 11:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  octave 4.2.1-7
Comment by Antonio Rojas (arojas) - Tuesday, 28 March 2017, 11:07 GMT
Seems to be a race condition, I can reproduce on my HDD desktop but not on my SSD laptop. Please report it upstream.
Comment by Roelof Rietbroek (Strawpants) - Tuesday, 28 March 2017, 11:28 GMT Comment by Roelof Rietbroek (Strawpants) - Tuesday, 28 March 2017, 11:31 GMT
FYI this happened on my SSD laptop
Comment by Jesus Alonso (doragasu) - Tuesday, 05 September 2017, 12:14 GMT
I had also this problem from CLI. I had alias octave='octave -qW' on .bashrc and for me starting octave always caused this problem on exit. I tried removing the '-q' switch (octave -W) and this way the program exits gracefully. Maybe the bug only happens when using -q, and the GUI spawns octave using this switch.

I have notified upstream, hope it gets fixed.
Comment by Eli Schwartz (eschwartz) - Thursday, 07 September 2017, 23:41 GMT
The upstream bug report indicates this commit should fix the issue: https://hg.savannah.gnu.org/hgweb/octave/rev/16fae04366b2

Loading...