Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53460 - [mumble] crash after recent openssl update

Attached to Project: Community Packages
Opened by Rasmus Steinke (rasi) - Sunday, 26 March 2017, 13:42 GMT
Last edited by Antonio Rojas (arojas) - Monday, 24 April 2017, 16:28 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Pierre Schmitz (Pierre)
Sven-Hendrik Haase (Svenstaro)
Antonio Rojas (arojas)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: testing has updated openssl to 1.1.0 lately
and packages were rebuild to make use of it.

However mumble does not work even after rebuilding against
this version


Additional info:
* package version(s)
openssl: 1.1.0e-1
mumble: 1.2.19-2

gdb output of mumble:

Thread 1 "mumble" received signal SIGSEGV, Segmentation fault.
0x00007ffff3da24c1 in ?? () from /usr/lib/libQtNetwork.so.4
(gdb) bt full
#0 0x00007ffff3da24c1 in () at /usr/lib/libQtNetwork.so.4
#1 0x00007ffff3d8ccce in () at /usr/lib/libQtNetwork.so.4
#2 0x00007ffff3d8ce42 in () at /usr/lib/libQtNetwork.so.4
#3 0x00007ffff3d8c7b1 in () at /usr/lib/libQtNetwork.so.4
#4 0x00007ffff3d8cbba in QSslCertificate::QSslCertificate(QByteArray const&, QSsl::EncodingFormat) () at /usr/lib/libQtNetwork.so.4
#5 0x0000000000580ca1 in CertWizard::importCert(QByteArray, QString const&) ()
#6 0x000000000043eb6e in main ()


This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 24 April 2017, 16:28 GMT
Reason for closing:  Fixed
Comment by Rasmus Steinke (rasi) - Sunday, 26 March 2017, 13:44 GMT
Looking at the output, this might well be an actual issue in qt4 rather than in mumble itself.
Comment by Jelle van der Waa (jelly) - Sunday, 26 March 2017, 14:53 GMT
For further completeness, qt4 is rebuild against openssl-1.0 (since it's well old)
Comment by Jan de Groot (JGC) - Wednesday, 29 March 2017, 09:46 GMT
This is caused by linking two different versions of OpenSSL.

qt4 was compiled with OpenSSL 1.0, mumble links against 1.1. This can't work. Mumble has to be recompiled with 1.0 until qt4 works with 1.1
Comment by Sven-Hendrik Haase (Svenstaro) - Wednesday, 29 March 2017, 13:44 GMT
Yes, fixed with a rebuild into [community-testing]. I'm adding Pierre to this issue so that he is aware that he has to move mumble and murmur into [community] when the rebuild stuff is moved.

Loading...