Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53428 - [pacman] Utilize sources.archlinux.org infrastructure as upstream fallback.

Attached to Project: Arch Linux
Opened by Alif (alive4ever) - Thursday, 23 March 2017, 10:08 GMT
Last edited by Allan McRae (Allan) - Thursday, 23 March 2017, 10:17 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Currently, there is no way to rebuild package when upstream website is not available.

Arch has an incomplete cache of source packages at https://sources.archlinux.org/, which can be
used as fallback for downloading source packages in case of unavailable upstream website. This
should be used extensively by Arch developers to cache upstream tarball so it will cache all source
packages for core, extra, and community repository.

For packages with CVS-based upstream source, mirror of the upstream CVS should also be available on
sources.archlinux.org as fallback for these type of packages

Pacman, especially makepkg, should be able to utilize the Arch source mirror as fallback to fetch the
upstream source when this happens.

Additional info:
* package version(s): 5.0.1-4
* config and/or log files etc. : none


Steps to reproduce:

1. Rebuild a package with dead upstream, such as dash ( FS#53426 ) in an empty directory.
2. Package build fails because upstream source can't be found and pacman/makepkg doesn't have a fallback mechanism to fetch upstream source when this happens.


This task depends upon

Closed by  Allan McRae (Allan)
Thursday, 23 March 2017, 10:17 GMT
Reason for closing:  Won't implement
Additional comments about closing:  Pacman is not Arch Linux specific

Loading...