Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53394 - [rethinkdb] Users are created too late

Attached to Project: Community Packages
Opened by Janne Heß (das_j) - Tuesday, 21 March 2017, 12:02 GMT
Last edited by Jelle van der Waa (jelly) - Tuesday, 30 April 2019, 13:21 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Anatol Pomozov (anatolik)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The .install file of RethinkDB contains a line that chowns /var/lib/rethinkdb to the user rethinkdb.
The user, however, is not created yet. It will be created as sysuser. This takes place after the install file.

Additional info:
* package version(s)

rethinkdb 3.2.0-1

* config and/or log files etc.

Pacman output:

(2/2) installing rethinkdb [----------------------------------------] 100%
Recursively removing directory /var/lib/rethinkdb/default/tmp
chown: invalid user: ‘rethinkdb:rethinkdb’
error: command failed to execute correctly
:: Running post-transaction hooks...
(1/4) Updating system user accounts...

Steps to reproduce:

Install RethinkDB on a system where it was never installed before.
This task depends upon

Closed by  Jelle van der Waa (jelly)
Tuesday, 30 April 2019, 13:21 GMT
Reason for closing:  Deferred
Additional comments about closing:  rethinkdb has been moved to the AUR
Comment by Anatol Pomozov (anatolik) - Wednesday, 22 March 2017, 16:24 GMT
Part of the problem is that rethinkdb.install script tried to do too much. It creates default database instance. Truly 'arch way' would let user to create rethinkdb database manually when it is needed. In this case rethinkdb.install file can be removed.
Comment by NicoHood (NicoHood) - Thursday, 21 September 2017, 18:03 GMT
@anatol I just wanted to report the exact same issue. I want to write a similar pkg that also creates his own user. Beside the database creation the chown seems correct to me. Shouldnt we make the sysuser hook a pre instead of post hook?
Comment by Eli Schwartz (eschwartz) - Sunday, 24 September 2017, 15:41 GMT
Pre- hooks run before the package is installed/upgraded... the sysusers file will not exist yet...

There is no such thing as a hook that runs after the package files are extracted and before the install script is run. That's kind of what an install script is *for*.

I fail to see what the install script even accomplishes at all, running a default invocation of the software to create defaults should be left to the user, if you really want it could be a post_install message I guess.
Comment by Eli Schwartz (eschwartz) - Monday, 19 March 2018, 05:40 GMT
@anatolik, so, can we just remove that install file and call it a day?

Loading...