Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53355 - [vim-airline] raise error on window change event

Attached to Project: Community Packages
Opened by Lucjan B (lucck) - Friday, 17 March 2017, 22:53 GMT
Last edited by Alexander F. Rødseth (xyproto) - Tuesday, 21 March 2017, 14:42 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

vim-airline doesn't work after package upgrade. On window change event vim-airline report undefined variable error.




Additional info:
* package version: vim-airline 0.8-3 vim-airline-themes r1230.793ce66-1
* Log error included in the log.txt file


Steps to reproduce:

start vim


   log.txt (1.4 KiB)
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Tuesday, 21 March 2017, 14:42 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Monday, 20 March 2017, 18:10 GMT
Kind of looks like a theme issue
Comment by Alexander (SIDS) - Tuesday, 21 March 2017, 13:45 GMT
I've made some research and worked out a solution.

Description:
By default, vim-airline plugin uses 'dark' theme (/usr/share/vim/vimfiles/autoload/airline/themes/dark.vim).
But PKGBUILD removes it:
...
30 # This one conflicts with vim-airline-themes
31 rm "$pkgdir/usr/share/vim/vimfiles/autoload/airline/themes/dark.vim"
...

More description:
'dark.vim' was located in both git-repos 'vim-airline' and 'vim-airline-theme'. To prevent conflict, we deleted 'dark.vim' from the first package and used the file from the second package.
Then 'dark.vim' was deleted from 'vim-airline-theme' at this commit https://github.com/vim-airline/vim-airline-themes/commit/332678ba862e0fccf48ef8b7fdb836dd26f2a7f5.
So after installing both vim-airline and vim-airline-theme, the file is missing.

Solution:
Delete line 31 from PKGBUILD file:
31 rm "$pkgdir/usr/share/vim/vimfiles/autoload/airline/themes/dark.vim"

Comment by Alexander F. Rødseth (xyproto) - Tuesday, 21 March 2017, 14:42 GMT
Hi, thanks for reporting. The updated package should appear in [community] shortly, without line 31.

Loading...