Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53346 - [testing] man-pages file `/usr/share/man/man3/explicit_bzero.3.gz` conflict with libbsd

Attached to Project: Arch Linux
Opened by Shulhan (sulhan) - Friday, 17 March 2017, 11:07 GMT
Last edited by Antonio Rojas (arojas) - Friday, 17 March 2017, 11:15 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

When updating all packages, including `man-pages`, pacman will fail because file `/usr/share/man/man3/explicit_bzero.3.gz` is already exist in filesystem.

Additional info:

Current installed version,

* man-pages 4.09-1
* libbsd 0.8.3-1

Steps to reproduce:

* Enable testing repo
* Run pacman update `pacman -Syu man-pages`

It will output something like these,

```
master ms 1 % sudo pacman -S man-pages
resolving dependencies...
looking for conflicting packages...

Package (1) Old Version New Version Net Change

testing/man-pages 4.09-1 4.10-1 0.01 MiB

Total Installed Size: 5.62 MiB
Net Upgrade Size: 0.01 MiB

:: Proceed with installation? [Y/n]
(1/1) checking keys in keyring [########################################################################] 100%
(1/1) checking package integrity [########################################################################] 100%
(1/1) loading package files [########################################################################] 100%
(1/1) checking for file conflicts [########################################################################] 100%
error: failed to commit transaction (conflicting files)
man-pages: /usr/share/man/man3/explicit_bzero.3.gz exists in filesystem
Errors occurred, no packages were upgraded.
```

Looking at the owner of confict file,

```
master ms 0 % pacman -Qo /usr/share/man/man3/explicit_bzero.3.gz
/usr/share/man/man3/explicit_bzero.3.gz is owned by libbsd 0.8.3-1
```
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 17 March 2017, 11:15 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#53342 

Loading...