Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53343 - [mkinitcpio] -s --save "Save build directory" flag does not output where the saved directory is

Attached to Project: Arch Linux
Opened by Ceriel Jacobs (cj1) - Friday, 17 March 2017, 00:25 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 01 October 2017, 17:40 GMT
Task Type Feature Request
Category Arch Projects
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Adding the -s --save "Save build directory" flag doesn't output on console where the directory is.
Not even when adding flag -v --verbose.
The directory is not saved in /tmp (ls -l /tmp = total 0)

Or it is a bug that the saved directory is actually not saved at all.

Additional info:
* mkinitcpio version 22
* config:
MODULES="ehci-hcd ehci-pci"
BINARIES=""
FILES="/etc/modprobe.d/modprobe.conf"
HOOKS="base udev autodetect modconf block filesystems keyboard fsck"
COMPRESSION="lz4"
COMPRESSION_OPTIONS="-9"

Steps to reproduce:
mkinitcpio -sp linux
mkinitcpio -s -p linux
mkinitcpio -sv -p linux
mkinitcpio -s -v -p linux
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 01 October 2017, 17:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  https://git.archlinux.org/mkinitcpio.git /commit/?id=91b212551a5066
Comment by Dave Reisner (falconindy) - Friday, 17 March 2017, 16:42 GMT
This works. It's because you're trying to involve a preset that it doesn't.

$ mkinitcpio -s
==> Starting dry run: 4.10.2-1-ARCH
-> Running build hook: [base]
-> Running build hook: [systemd]
-> Running build hook: [strip]
==> Generating module dependencies
==> Dry run complete, use -g IMAGE to generate a real image
==> build directory saved in /tmp/mkinitcpio.5t1c1J
Comment by Ceriel Jacobs (cj1) - Friday, 17 March 2017, 16:52 GMT
"Feature request"or "Bug"?

The documentation doesn't list for -s (--save) something like "This flag is incompatible with -p flag".
Comment by Dave Reisner (falconindy) - Friday, 17 March 2017, 17:03 GMT
The category doesn't make the change any less or more trivial. See: https://git.archlinux.org/mkinitcpio.git/commit/?id=91b212551a5066
Comment by Ceriel Jacobs (cj1) - Friday, 17 March 2017, 17:06 GMT
Thank you for the link to the source code. Though I don't understand that computer language. I need extensive comments in the code before I can understand what is happening.

Loading...