Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53318 - [gtk3] dconf should be a an optional dependency

Attached to Project: Arch Linux
Opened by kaovo (kaovo) - Wednesday, 15 March 2017, 08:19 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 15 March 2017, 13:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

dconf is a required dependency of gtk3 however it's not required for gtk3 to work. This affects those who do not want an extra daemon running in the background.

The dconf documentation makes no mention of GTK. dconf is accessed by applications -- not GTK -- which indicates the dependency should be on applications themselves.

https://wiki.gnome.org/action/show/Projects/dconf
https://wiki.gnome.org/Projects/dconf/SystemAdministrators

NOTE: Removing dconf as a required dependency for gtk3 would involve updating PKGBUILDs of individual applications.

Additional info:
* gtk3 3.22.10-1

Steps to reproduce:

1. Install gtk3 without dconf.
[code]pacman -S -dd gtk3[/code]
or
[code]yaourt -S gtk3 --assume-installed dconf[/code]
2. Run popular applications (such as firefox or transmission-gtk) to see that dconf is not required.
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 15 March 2017, 13:59 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Wednesday, 15 March 2017, 13:56 GMT
dconf was re-added on purpose:
https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/gtk3&id=1676bef3772215604648f5136309883354856ced

From the changelogs:
* The GtkFileChooser now uses GSettings to store its settings
instead of the keyfile ~/.config/gtk-2.0/gtkfilechooser.ini

Guess where these settings are stored: dconf

Loading...