Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53313 - [tuxguitar] Sound delay when returning from hibernation

Attached to Project: Community Packages
Opened by desbma (desbma) - Tuesday, 14 March 2017, 18:59 GMT
Last edited by Balló György (City-busz) - Sunday, 07 January 2018, 21:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
When returning from hibernation and playing a tab, there is a several seconds delay in the audio.

Additional info:
* package version: tuxguitar 1.4-2, fluidsynth NOT installed
* config: default TuxGuitar config after installation, nothing altered
* all package up to date.

Steps to reproduce:
1. Open a Guitar tab with TuxGuitar
2. Play it, then stop
3. Hibernate
4. Return from hibernation
5. Play the tab again

=> The UI tab animation starts right away, but the sound only comes a few seconds after hitting play. Clicking start/stop several times does NOT fix it: UI reacts to actions, audio too but still with several seconds delay. Restarting TuxGuitar does fix it.

I'm not sure if this is a kernel (hibernation), pulseaudio or tuxguitar bug. I tried playing a song with Clementine player, and hibernating, and could not reproduce the same delay when returning from hibernation, so I'm betting on tuxguitar.
This task depends upon

Closed by  Balló György (City-busz)
Sunday, 07 January 2018, 21:16 GMT
Reason for closing:  Won't fix
Comment by Balló György (City-busz) - Sunday, 07 January 2018, 21:16 GMT

Loading...