Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53248 - [util-linux] setpriv not in package

Attached to Project: Arch Linux
Opened by einar (esjurso) - Saturday, 11 March 2017, 06:34 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 02 December 2017, 16:30 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Anatol Pomozov (anatolik)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

util-linux contains a rather useful utility called setpriv (http://man7.org/linux/man-pages/man1/setpriv.1.html) which isn't currently available in the package.

after some minor research on why this isnt available i found out it requires libcap-ng to function well and the build utils of util-linux check for this before enabling it. thus if we want the tool libcap-ng needs to be moved into core. this doesn't seem too unreasonable given that libcap-ng is very small.
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 02 December 2017, 16:30 GMT
Reason for closing:  Fixed

Loading...