Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53215 - [firefox] 52 crashes on html5 video

Attached to Project: Arch Linux
Opened by Andrey Kashlak (andreymal) - Wednesday, 08 March 2017, 14:56 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 09 March 2017, 15:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 2
Private No

Details

After upgrading to firefox 52.0-2 it now crashes on htmt5 video (for example any YouTube video).
Firefox 51 worked good.
Original Firefox 52 downloaded from mozilla.org also works good.

dmesg prints error "traps: ImageBridgeChil[19159] trap invalid opcode ip:7fe78daff001 sp:7fe76d5fe430 error:0 in libxul.so[7fe78ca96000+3cd9000]"

My device: Acer Aspire E5-571G, Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz

Video with demonstration of crash: https://www.youtube.com/watch?v=h_7S7dTSdkw
This task depends upon

Comment by Andrey Kashlak (andreymal) - Thursday, 09 March 2017, 18:51 GMT
Hm, Firefox works good today. I don't know what was it ._.
Comment by Florus Dastious (dastious) - Thursday, 09 March 2017, 22:47 GMT
Same for me on i5-4690K(4.9.13-1-lts) :

dmesg :
Chrome_ChildThr[16048]: segfault at 0 ip 000055a18e91cda1 sp 00007fcfad3fe390 error 6 in plugin-container[55a18e918000+1a000]
or
Chrome_ChildThr[20529]: segfault at 0 ip 000055805de06da1 sp 00007fe6898fe390 error 6 in plugin-container[55805de02000+1a000]

and journalctl in the file.
Comment by ArchLoy (Loy) - Friday, 07 April 2017, 21:19 GMT
Same problem here, it's not only with video but it can works a long times before crash or just 30 minutes.

Same error on dmesg, uname -a : Linux lilith 4.10.2-1-ARCH #1 SMP PREEMPT Mon Mar 13 17:13:41 CET 2017 x86_64 GNU/Linux

Loading...