Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53214 - xf86-video-nouveau-1.0.13-3-x86_64 breaks xorg

Attached to Project: Arch Linux
Opened by Bernhard Holzmayer (bholzmayer) - Wednesday, 08 March 2017, 14:08 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 22 March 2017, 14:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: after xorg starting cinnamon desktop, only one of two screens is alive, and I cannot interact at all. Doesn't accept any mouse or keyboard events


Additional info:
* xf86-video-nouveau-1.0.13-3-x86_64 (builddate=1488871530, from Mar 7, 7:25:30)
* just updating system with 'pacman -Syu', only relevant changed file was this one, rest of xorg, cinnamon etc. was not changed.
* pacman did not complain (I checked the log). Only the typical line indicating 1.0.13-2 -> 1.0.13-3 migration.
* I can use the keyboard to switch to console (Ctrl-Alt-2) and/or to shutdown Xorg (Ctrl-Alt-Bsp), but I cannot switch screens (Ctrl-Alt-Arrow)
* I have two monitors attached, which Xorg used to identify correctly with older driver; this one connects only the first one.

after downgrading to 1.0.13-2 everything is fine again.

Steps to reproduce:
my xorg session is started in user mode from bash using the startx script
~/.xinitrc contains a line like
exec cinnamon-session

This is a productive system, so I cannot play with it at any time.
But if helpful, I could retrieve additional information. Just let me know and be aware that it might take a day.

For me, this bug is not (yet) severe, because the downgrade works fine.


This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 22 March 2017, 14:45 GMT
Reason for closing:  None
Comment by Laurent Carlier (lordheavy) - Wednesday, 08 March 2017, 15:24 GMT
Have you tried the modesetting driver?
Comment by Ike Devolder (BlackEagle) - Thursday, 09 March 2017, 10:00 GMT
I have plasma5 with dual head at home with no issues
And here at work I have i3 also started from .xinitrc without issues (also 2 screens)

all with the mentioned version of nouveau
Comment by Bernhard Holzmayer (bholzmayer) - Thursday, 09 March 2017, 10:52 GMT
Here is the lspci output of the graphics controller where I have the issues:

01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 630 OEM] (rev a1) (prog-if 00 [VGA controller])
Subsystem: PC Partner Limited / Sapphire Technology Device 0630
Flags: bus master, fast devsel, latency 0, IRQ 26
Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at f0000000 (64-bit, prefetchable) [size=32M]
I/O ports at e000 [size=128]
Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [b4] Vendor Specific Information: Len=14 <?>
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Capabilities: [900] #19
Kernel driver in use: nouveau
Kernel modules: nouveau

Comment by Bernhard Holzmayer (bholzmayer) - Monday, 13 March 2017, 06:35 GMT
Hello again,
just to inform you: described problem still exists after today's system upgrade to newer linux kernel "4.10.1-1-ARCH #1 SMP PREEMPT Sun Feb 26 21:08:53 UTC 2017 x86_64 GNU/Linux".
After system upgrade X/cinnamon hangs with unusable mouse/keyboard.
After downgrade of xf86-video-nouveau to release 1.0.13-2, everything is fine.
Find appended today's pacman log.
Kind regards,
Bernhard
Comment by Bernhard Holzmayer (bholzmayer) - Wednesday, 15 March 2017, 08:24 GMT
after linux kernel upgrade (4.10.1-1 -> 4.10.2-1)
and gtk3 update to 3.22.10-1
and additionally installing lightdm (1:1.20.0-2)
I can work witch the newest nf86-video-nouveau (1.0.14-1) as ever before.
I guess there's still an issue with user starting X which is now failing completely.

But since starting via LightDM works fine, I can verify, that the nouveau driver itself seems to work perfectly.
I'd propose to close this task.

Loading...