Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53208 - tesseract not recognized by gscan2pdf

Attached to Project: Community Packages
Opened by Friedrich Strohmaier (bitsfritz) - Tuesday, 07 March 2017, 23:25 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Thursday, 09 March 2017, 14:22 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
tesseract-3.05.00-1 is no longer recognized by gscan2pdf as OCR application.
downgrading to version 3.04.01-2 gets it back into the OCR application list.

Additional info:
* package version(s)
3.05.00-1
* config and/or log files etc.
none

Steps to reproduce:
1 Install tesseract-3.05.00-1
2 start gscan2pdf
3 open some image with text
4 select Tools -> OCR
5 select OCR Engine -> [tesseract does not appear]

desired result:
1 downgrade to tesseract-3.04.01-2 [1]
2 ..
..
5 select OCR Engine -> tesseract

[1]
https://archive.archlinux.org/packages/t/tesseract/tesseract-3.04.01-2-x86_64.pkg.tar.xz

Comment left in aur gscan2pdf site:
https://aur.archlinux.org/packages/gscan2pdf/

This task depends upon

Closed by  BartÅ‚omiej Piotrowski (Barthalion)
Thursday, 09 March 2017, 14:22 GMT
Reason for closing:  None
Additional comments about closing:  gscan2pdf isn't officially supported by Arch
Comment by Sergej Pupykin (sergej) - Wednesday, 08 March 2017, 19:20 GMT
I guess you need to look into gscan2pdf-1.7.2/lib/Gscan2pdf/Tesseract.pm. It contains some magic detecting tesseract using "which tesseract", "tesseract -v", "tesseract -l", etc.

Loading...