Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53207 - [python-cairocffi] cairosvg fails to start

Attached to Project: Community Packages
Opened by Antony Lee (anntzer) - Tuesday, 07 March 2017, 23:21 GMT
Last edited by Felix Yan (felixonmars) - Tuesday, 21 March 2017, 07:43 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Jiachen Yang (farseerfc)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
/usr/bin/cairosvg completely fails to run on a vanilla install of pyhton-cairosvg 2.0.1-1.

Steps to reproduce:
$ pacman -S python-cairosvg
$ cairosvg -h

Traceback (most recent call last):
File "/usr/bin/cairosvg", line 11, in <module>
load_entry_point('CairoSVG==2.0.1', 'console_scripts', 'cairosvg')()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 560, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2648, in load_entry_point
return ep.load()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2302, in load
return self.resolve()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2308, in resolve
module = __import__(self.module_name, fromlist=['__name__'], level=0)
File "/usr/lib/python3.6/site-packages/cairosvg/__init__.py", line 29, in <module>
from . import surface
File "/usr/lib/python3.6/site-packages/cairosvg/surface.py", line 24, in <module>
import cairocffi as cairo
File "/usr/lib/python3.6/site-packages/cairocffi/__init__.py", line 18, in <module>
from ._ffi import ffi
File "/usr/lib/python3.6/site-packages/cairocffi/_ffi.py", line 3, in <module>
from xcffib._ffi import ffi as _ffi0
ModuleNotFoundError: No module named 'xcffib'
This task depends upon

Closed by  Felix Yan (felixonmars)
Tuesday, 21 March 2017, 07:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-cairocffi 0.8.0-2
Comment by Doug Newgard (Scimmia) - Wednesday, 08 March 2017, 15:32 GMT
Looks like this is no longer optional.

Loading...