Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53126 - [evince] Dependency on gtk3-print-backends is missing

Attached to Project: Arch Linux
Opened by Michael Kogan (Photon) - Wednesday, 01 March 2017, 11:08 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 01 March 2017, 12:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Due to gtk3-print-backends missing as dependency, printing through evince is only possible after installing gtk3-print-backends by hand.

Additional info:
* package version: 3.22.1-1


Steps to reproduce:

Install evince, try to print a document. The printers list will only show "Print to document", no further printers.
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 01 March 2017, 12:33 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#52789 
Comment by Christian Hesse (eworm) - Wednesday, 01 March 2017, 11:10 GMT
Package gtk3-print-backends is an optional dependency of gtk3:

gtk3-print-backends: Printing
Comment by Michael Kogan (Photon) - Wednesday, 01 March 2017, 11:23 GMT
True, didn't know that. Please consider the following user case:

A new Xfce install, gtk3 is "preinstalled" as dependency of other packages, the user didn't care to read through its optional dependency list. gtk3-print-backends is not installed. The user later installs evince and runs into the described problem. I agree that gtk3-print-backends should be only optional for gtk3, but for evince printing is core functionality and imho should be added as its proper dependency. At least add it as optional dependency for evince as well to draw the user's attention to the fact that it is required for printing functionality in evince while installing it.
Comment by Jan de Groot (JGC) - Wednesday, 01 March 2017, 12:32 GMT
There are so many applications that you want to print for, should we add the optdepend for all of them?

Loading...