Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53093 - [nvidia-340xx-utils] 340.102-5 breaks -lGL linking

Attached to Project: Arch Linux
Opened by Martin Tůma (tumic) - Monday, 27 February 2017, 00:27 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 27 February 2017, 01:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Upgrade to nvidia-340xx-utils version 340.102-5 breaks compile time OpenGL (-lGL) linking.
The reason is, that /usr/lib/nvidia is not in the (compile time) linker search path. When added "manually" using the LIBRARY_PATH environment variable, the linking succeeds.

With older versions (prior to removing nvidia-340xx-libgl) -lGL linking worked fine without fiddling with the search path.

Steps to reproduce:
With nvidia-340xx-utils installed (as the only libgl package) try to compile any project that uses -lGL, eg. any QT5 project that uses OpenGL.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 27 February 2017, 01:01 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#53069 

Loading...