Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53082 - make message more prevalent: gtk 3.22 optionally requires gtk3-print-backends

Attached to Project: Arch Linux
Opened by John Henderson (jwhendy) - Saturday, 25 February 2017, 16:55 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 25 February 2017, 17:18 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: the upgrade from gtk3 3.20 -> 3.22 now required gtk3-print-backends for printing from gtk applications. I must not print often as it appears this update happened for me back in 2016 October and I just ran into it yesterday when Evince did not show any printers I knew to be installed via cups @ localhost:631. Googling around yields many instances of users having the same issue, for example:

- https://forum.xfce.org/viewtopic.php?id=11195
- http://unix.stackexchange.com/questions/319363/evince-does-not-show-printers

I wasn't sure where to file this as technically this is cited in the wiki:
- https://wiki.archlinux.org/index.php/CUPS#Installation

That said, as shown in the xfce logs above (and from checking my own log), the upgrade from 3.20 -> 3.22 gave no install message about the optional dependency. So, I'm filing this but more as a place to ask: when a package changes it's opt depends or functionality that used to be part of it no longer is, do we feel that Arch has an adequate message to make this known to the user?

I *think* if one were installing fresh it would print out the optdepends... but I'm not sure. If so, it appears that pacman does not have a method to check for current optdepends vs. former ones and send a message about the change. I think the main thing about this change that's important is it removed functionality that was previously there. Typically optdepends add additional functionality (like adding gvfs to thunar to see manage mountable drives or have access to trash). In this case, that functionality was already present and then was removed.

As a simple alternative, perhaps anything that changes provided features should be mentioned in the main archlinux.org news as that's a good goto for any "odd" behavior one starts noticing.


Additional info:
* package version(s)

gtk 3.22 and any gtk3 printing application

* config and/or log files etc.


Steps to reproduce:
- have gtk3 3.20 installed
- print at will from, e.g. firefox or evince
- upgrade to gtk 3.22 via pacman -Syu
- find to your surprise that you can no longer print to installed cups printers from e.g. firefox or evince
- google to find that behavior has changed and you need to pacman -S gtk3-print-backends


Thanks for considering this and feel free to re-file or suggest I put it elsewhere. I didn't know how to fit this in under a typical package bug report.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 25 February 2017, 17:18 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Pacman told you about the new optional dep when you updated

Loading...