Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53007 - [cryptsetup] crypttab password entry skipped while typing

Attached to Project: Arch Linux
Opened by Lukas B (teateawhy) - Saturday, 18 February 2017, 13:41 GMT
Last edited by Christian Hesse (eworm) - Saturday, 04 November 2017, 22:30 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

To reproduce:
In /etc/crypttab create an entry with the <password> field set to none.

Systemd asks for a password, but after i typed half of it, it skips over the password entry before i can press enter, and nothing happens.
Some characters of the password are typed into the console and visible in clear text after the password entry is skipped.
This task depends upon

Closed by  Christian Hesse (eworm)
Saturday, 04 November 2017, 22:30 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Expected behaviour.
Comment by Jan de Groot (JGC) - Saturday, 18 February 2017, 15:50 GMT
Do you have a timeout set?
Comment by Lukas B (teateawhy) - Saturday, 18 February 2017, 16:02 GMT
I tried it with timeout=180 and without timeout setting, same result.
Comment by Lukas B (teateawhy) - Saturday, 18 February 2017, 16:16 GMT
This seems to happen because of the "nofail" parameter i have specified. Removing the "nofail" parameter solves the issue.
Not sure if the behaviour described is intended or not. It seems silly to show a password entry box and then quickly hide it again.
Comment by Christian Hesse (eworm) - Saturday, 04 November 2017, 22:30 GMT
The behaviour is expected if you give "nofail" parameter.
If you think the passphrase dialog is wrong discuss with systemd upstream.

Loading...