Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52969 - [libinput] XWayland server becomes unresponsive on gnome shell

Attached to Project: Arch Linux
Opened by CubeTheThird (CubeTheThird) - Wednesday, 15 February 2017, 01:33 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 21 March 2018, 18:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After the recent update to package version 1.19.1-2, running Gnome Shell on Wayland will randomly become unresponsive. All keyboard and mouse input appears to stop (the Caps Lock light does not even turn on), and the display becomes frozen. The system itself is still running, as I am able to properly shutdown and reboot using my PC's power button, and applications running appear to continue execution (e.g. audio keeps playing).

In the system's journals, the only seemingly useful error message I've uncovered is:
org.gnome.Shell.desktop[958]: Key repeat discarded, Wayland compositor doesn't seem to be processing events fast enough!

While I cannot guarantee the recent update is the cause of this issue, it seems to have manifested after its installation.
I have also yet to find a pattern to the cause, as I've had different applications running when it occurs.

Additional info:
Xorg-server (etc.) version 1.19.1-2
gnome-shell 3.22.2+18+gdf7727a-1
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 21 March 2018, 18:53 GMT
Reason for closing:  Fixed
Comment by Jan de Groot (JGC) - Wednesday, 15 February 2017, 10:26 GMT
The patches applied to 1.19.1-2 vs 1.19.1-1 only touch hw/xfree86, XWayland code is in hw/xwayland, so the patches in -2 should not affect xwayland at all.

Comment by CubeTheThird (CubeTheThird) - Thursday, 16 February 2017, 00:44 GMT
Hmm so then it sounds like it's caused by some other update then. I was under the impression it was with XWayland since I have no issues under X11. I will further investigate and identify any other package I updated at that time which may be causing the issue.
Comment by Jan de Groot (JGC) - Thursday, 16 February 2017, 08:26 GMT
Wayland itself doesn't handle input. The compositor does input handling through libinput. Areas to look for issues:
- kernel
- libinput
- compositor (weston, mutter, etc).
Comment by CubeTheThird (CubeTheThird) - Thursday, 16 February 2017, 19:49 GMT
Mutter and Gnome haven't been updated in some time, so I doubt they are the cause. I've ruled out libinput (specifically xf86-input-libinput) as I noticed it recently updated, but testing using the previous version yielded the same result. Guess the next thing to test is the kernel.
Comment by Gemini (Gemini) - Wednesday, 04 October 2017, 00:08 GMT
I can still experiment the issue and journalctl -r shows a lot of the following error message :

Key repeat discarded, Wayland compositor doesn't seem to be processing events fast enough!

Additionnal information that might help track the issue:
the freeze only happens when I input japanese characters.

For example, let's say I input the letters arigatou. The japanese input software will then propose me a list of japanese characters to select from. I can iterate that list with the arrow keys or the mouse and chose the appropriate writing.

This is the only time I have the freeze: when I select the appropriate writing. The freeze, however, seems random.
Comment by Mike Appleby (appleby) - Wednesday, 04 October 2017, 15:58 GMT
My experience is similar to Gemini, above. I don't have a reproducible test case, but I was also inputting Japanese characters both times this happened to me recently.

When it happens my laptop is unresponsive to keyboard and mouse input, and I have to hard reset. My journalctl logs contain the same error message as in the bug description, repeated many times per second, e.g.

Oct 03 13:57:02 march org.gnome.Shell.desktop[1340]: Key repeat discarded, Wayland compositor doesn't seem to be processing events fast enough!
Oct 03 13:57:02 march org.gnome.Shell.desktop[1340]: Key repeat discarded, Wayland compositor doesn't seem to be processing events fast enough!
Oct 03 13:57:02 march org.gnome.Shell.desktop[1340]: Key repeat discarded, Wayland compositor doesn't seem to be processing events fast enough!
Oct 03 13:57:02 march org.gnome.Shell.desktop[1340]: Key repeat discarded, Wayland compositor doesn't seem to be processing events fast enough!
Oct 03 13:57:02 march org.gnome.Shell.desktop[1340]: Key repeat discarded, Wayland compositor doesn't seem to be processing events fast enough!
Oct 03 13:57:02 march org.gnome.Shell.desktop[1340]: Key repeat discarded, Wayland compositor doesn't seem to be processing events fast enough!

I guess it could be an ibus or ibus-anthy bug, but googling for the error message lead me here, so I thought I'd chime in.

I had a go at finding a reproducible case by inputting lots of Japanese characters and continuously cycling through the list of completions, but was not able to reproduce.

My version info:

linux-lts 4.9.52-1
xorg-server 1.19.3-3
wayland 1.14.0-1
gnome-shell 3.24.3-1
ibus 1.5.16-1
ibus-anthy 1.5.9-1
Comment by Gemini (Gemini) - Wednesday, 04 October 2017, 19:39 GMT
The bug is still there for me too, although I did a total reinstall of Archlinux.

Unfortunately, I still do not manage to find a precise reproducible test case and it is still very random. I might be able to type loads of japanese text without any problem, and some other days, I might have many freeze in a short time.
Comment by Matt Price (matt.price) - Thursday, 16 November 2017, 21:19 GMT
I'm seeing something similar, without japanese text as a precipitating event. Stil lthere for you, Gemini?
Comment by Laurent Carlier (lordheavy) - Saturday, 18 November 2017, 17:15 GMT
I think it's related to button debouncing code in libinput; see https://cgit.freedesktop.org/wayland/libinput/commit/?id=55d1bb1217388e99b9405654c14881a9ebf8f880

reaffecting the bug to libinput
Comment by Laurent Carlier (lordheavy) - Tuesday, 05 December 2017, 06:42 GMT
Is it fixed with libinput-1.9.3-1 ?
Comment by Gemini (Gemini) - Tuesday, 05 December 2017, 21:41 GMT
Matt Price, it is still there for me, yes. However, I did not update yet to libinput-1.9.3-1. I will write another about this later on.
Comment by Christophe Réquillart (crequill) - Wednesday, 13 December 2017, 10:34 GMT
Same problem here with gnome shell on wayland and libinput 1.9.3-1.

déc. 13 10:43:36 frcls4524 org.gnome.Shell.desktop[962]: Window manager warning: last_focus_time (88409013) is greater than comparison timestamp (88408999). This most likely represents a buggy client sending
déc. 13 10:43:30 frcls4524 org.gnome.Shell.desktop[962]: libinput error: libinput bug: timer event3 debounce short: offset negative (-190257)
déc. 13 10:43:30 frcls4524 org.gnome.Shell.desktop[962]: libinput error: libinput bug: timer event3 debounce: offset negative (-150693)
déc. 13 10:48:24 frcls4524 org.gnome.Shell.desktop[962]: Key repeat discarded, Wayland compositor doesn't seem to be processing events fast enough!

This problem seems appear when I switch from Nvidia drivers to nouveau.
linux 4.14.4-1
gnome-shell 3.26.2+9+ga3736d3a3-1
wayland 1.14.0-1
mesa 17.2.6-1
libinput 1.9.3-1
Comment by Andreas Radke (AndyRTR) - Wednesday, 21 February 2018, 09:34 GMT
Is this still an issue?
Comment by Christophe Réquillart (crequill) - Wednesday, 21 February 2018, 10:03 GMT
Not for me an issue. I always have these logs:

févr. 21 10:47:07 frcls4524 org.gnome.Shell.desktop[930]: libinput error: client bug: timer event3 debounce short: offset negative (-14ms)
févr. 21 10:47:07 frcls4524 org.gnome.Shell.desktop[930]: libinput error: client bug: timer event3 debounce: offset negative (-1ms)
févr. 21 10:11:19 frcls4524 org.gnome.Shell.desktop[930]: Window manager warning: last_user_time (76152069) is greater than comparison timestamp (76152041). This most likely represents a buggy client sending

But no more screen frozen.

linux 4.15.3-2
gnome-shell 3.26.2+14+g64c857e3f-1
wayland 1.14.0-1
mesa 17.3.4-1
libinput 1.10.0-1
Comment by Mike Appleby (appleby) - Thursday, 22 February 2018, 19:48 GMT
For what it's worth, my desktop crashed on Jan 30th and I had similar messages to crequill in my logs just before the crash. Screen went black for a few seconds, then the machine rebooted. I haven't had time to dig into the logs yet. Not sure if it's related or just a coincidence.

Jan 30 18:22:38 march org.gnome.Shell.desktop[1314]: libinput error: libinput bug: timer event16 debounce: offset negative (-4386)
Jan 30 18:22:38 march org.gnome.Shell.desktop[1314]: libinput error: libinput bug: timer event16 debounce short: offset negative (-17425)
Jan 30 18:23:03 march kernel: [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
Jan 30 18:23:03 march kernel: [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
Jan 30 18:30:22 march systemd[1]: Starting system activity accounting tool...
Jan 30 18:30:22 march systemd[1]: Started system activity accounting tool.
Jan 30 18:31:54 march org.gnome.Shell.desktop[1314]: libinput error: libinput bug: timer event16 debounce short: offset negative (-6890)
-- Reboot --

As far as I can tell from looking at pacman.log, these are the packages I had installed at the time of the crash. I've since upgraded linux-lts, xorg-server, and mesa.

linux-lts 4.9.78-1
gnome-shell 3.26.2+14+g64c857e3f-1
xorg-server 1.19.6-2
wayland 1.14.0-1
mesa 17.3.3-1
libinput 1.9.4-1
ibus 1.5.17-1
Comment by Andreas Radke (AndyRTR) - Wednesday, 21 March 2018, 13:47 GMT
Is this still an issue? We had many related updates.
Comment by Mike Appleby (appleby) - Wednesday, 21 March 2018, 17:12 GMT
I still have the "debounce: offset negative" messages in my logs, but I haven't had any crashes since the one on Jan 30th. However, it was always an intermittent issue and I have been away-from-keyboard for most of the last month-and-a-half, so it's hard to say for sure.

At the time of writing, these are the two most recent log messages in my journal. I see they now say "client bug" rather than "libinput bug", so I guess this is a problem with a buggy client? Other logs seem to indicate it's probably Chrome.

Mar 21 10:50:22 march org.gnome.Shell.desktop[27924]: libinput error: client bug: timer event16 debounce: offset negative (-10ms)
Mar 21 10:50:22 march org.gnome.Shell.desktop[27924]: libinput error: client bug: timer event16 debounce short: offset negative (-23ms)

Comment by Andreas Radke (AndyRTR) - Wednesday, 21 March 2018, 18:53 GMT
I guess the initial issue is fixed. The time event debounce messages should be something different. Please report this upstream and file a new bug here if you want.

Loading...