Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52965 - Oxygen-icons theme does not inherit gnome

Attached to Project: Arch Linux
Opened by Mitja Vardjan (mico) - Tuesday, 14 February 2017, 18:32 GMT
Last edited by Antonio Rojas (arojas) - Wednesday, 15 February 2017, 12:37 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When oxygen icons are used, some icons are not displayed, at least not in xfce. This has been a known issue (see https://bugs.archlinux.org/task/37309) and a possible solution is to append "gnome" icons to inheritance tree in /usr/share/icons/oxygen/index.theme

However, in the long run, this solution has drawbacks. The file has to be fixed again and again after each upgrade of oxygen-icons package, unless the file is added to NoExtract in /etc/pacman.conf. In the latter case, other things could break on package upgrade if the new package does not work properly with the old index.theme - this has happened to me before and it took me quite a while to figure out what was wrong.

Ideally, this would be fixed by oxygen-icons developers but since they have shown no interest to do that in 2014 (https://bugs.kde.org/show_bug.cgi?id=325966) and we still have the same issue in 2017, maybe the archlinux package could be modified to append "gnome" to inheritance tree. For example, to add something like this to PKGBUILD:

[code]sed -ri 's/^(Inherits=hicolor)$/\1,gnome/' "${pkgdir}/usr/share/icons/oxygen/index.theme"[/code]


Steps to reproduce:
Log into XFCE desktop, choose oxygen icons with the default index.theme. The web browser icon is blank.
This task depends upon

Closed by  Antonio Rojas (arojas)
Wednesday, 15 February 2017, 12:37 GMT
Reason for closing:  Won't implement
Comment by Jan de Groot (JGC) - Tuesday, 14 February 2017, 22:10 GMT
gnome is a deprecated icon theme that is replaced for 99% by adwaita-icon-theme. Don't know exactly how icons are selected, but for cursors the "default" theme inherits Adwaita.
Comment by Mitja Vardjan (mico) - Wednesday, 15 February 2017, 09:00 GMT
You are right, Adwaita is the newer theme and it also solves this issue.
So instead of adding gnome, could Adwaita be added to inheritance?

Example:
sed -ri 's/^(Inherits=hicolor)$/\1,Adwaita/' "${pkgdir}/usr/share/icons/oxygen/index.theme"

Thanks
Comment by Antonio Rojas (arojas) - Wednesday, 15 February 2017, 12:37 GMT
If XFCE is using a standard icon name which is missing from oxygen, open a request upstream to include it. Oxygen develpers are active and responsive to reasonable requests. If it's using a non-standard icon name, it's their job to provide a suitable fallback in hicolor. Adding artificial inheritance relations between completely unrelated icon themes is not the solution.

Loading...