Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52925 - unetbootin wrapper does not start the program correctly

Attached to Project: Community Packages
Opened by Dikiy (dikiy) - Saturday, 11 February 2017, 21:10 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 12 February 2017, 15:17 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

unetbootin wrapper hangs at startup.

Additional info:
package version: 625-1

Steps to reproduce:

start unetbootin. The windiw appears gray without any elements. After the window close there thrown a window with an errors.


The problem is, that pkexec does not forward environment variables. That means, that

export QT_X11_NO_MITSHM=1

at the start of the wrapper-file has no effect.

The workaround ist to change the pkexec line to the following:

pkexec --disable-internal-agent env QT_X11_NO_MITSHM=1 DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY /usr/bin/unetbootin.elf $@ 2>/tmp/_polkit_error
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 12 February 2017, 15:17 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#42030 

Loading...