Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52822 - [libarchive] regression from 3.2.1: some zip files are not correctly extracted

Attached to Project: Arch Linux
Opened by Peter Wu (Lekensteyn) - Thursday, 02 February 2017, 12:32 GMT
Last edited by Christian Hesse (eworm) - Friday, 03 February 2017, 09:06 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
"Since version 3.2.2, bsdtar fails to extract some files. 3.2.1 version works fine."
-- https://github.com/libarchive/libarchive/issues/822

Please consider applying this patch now, otherwise makepkg fails to build some Java projects (like dex2jar in AUR).
https://github.com/libarchive/libarchive/commit/2ecf8d1c1e1bdfc20b0aada90e356054a3054693

libarchive 3.2.2-2
This task depends upon

Closed by  Christian Hesse (eworm)
Friday, 03 February 2017, 09:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  libarchive 3.2.2-3 in [testing]

Loading...