Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52808 - [xorg-server] Request: apply upstream patches to avoid SIGSEGV

Attached to Project: Arch Linux
Opened by Jon Gjengset (Jonhoo) - Wednesday, 01 February 2017, 16:55 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 08 February 2017, 11:54 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Since the upgrade to xorg-server 1.19.1, I, and other Arch users (https://bbs.archlinux.org/viewtopic.php?id=221958, https://bbs.archlinux.org/viewtopic.php?pid=1688089) have been experiencing occasional X crashes. A bug was filed upstream at https://bugs.freedesktop.org/show_bug.cgi?id=99431, and later identified as a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=99358. Patches for the latter have been posted and tested, and seem to resolve the issue, though a new upstream release has not yet been cut.

It would be great if the patches from https://bugs.freedesktop.org/show_bug.cgi?id=99358 could be applied to the Arch package to stop these crashes from happening until a release is published.
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 08 February 2017, 11:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 1.19.1-2 (testing).
Comment by Toni Mas (tmas) - Thursday, 02 February 2017, 09:40 GMT
Hi,

I hit this today. It seems to be a hard to hit bug, mainly for docked Thinkpads with multi-head monitors, and one of them rotated. It's solved here:

https://bugzilla.redhat.com/show_bug.cgi?id=1384486

By applying the patches from here:

https://bugs.freedesktop.org/show_bug.cgi?id=99358

I'm on a Thinkpad x220 with Intel i915 graphics, and my xorg-server is extra/xorg-server 1.19.1-1

Thank you.
Comment by Andreas Radke (AndyRTR) - Sunday, 05 February 2017, 10:15 GMT
These patches are only Fedora proved so far and not yet pushed to Xorg git repos. I suggest doing local builds for now until they commit them at least to Xorg git master or 1.19 stable branch.

Loading...