Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52775 - [plasma-workspace] crash during the login

Attached to Project: Arch Linux
Opened by Simon (Giggi) - Monday, 30 January 2017, 16:34 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 31 January 2017, 09:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

If I try to login in KDE it produce only a black screen and it is impossible to login.
Also I remove the directory ~/.kde4 the behavior do not change.

If I try to push ctrl + alt + del it appear the debug windows refereed to /usr/lib/ksmserver-logout-greeter

Additional info:
* package version(s)

plasma-workspace 5.8.5-1



This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 31 January 2017, 09:13 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Monday, 30 January 2017, 16:40 GMT
Without any logs or errors there is nothing we can do
Comment by Simon (Giggi) - Monday, 30 January 2017, 17:00 GMT
I've attached the kcrash log file.
I hope it is useful.
Comment by Antonio Rojas (arojas) - Monday, 30 January 2017, 17:05 GMT
is your home partition mounted with noexec?
Comment by Simon (Giggi) - Monday, 30 January 2017, 17:37 GMT
No.
It is mounted normally:

That's my entries for the root and home partitions:
UUID=43ffcf60-0458-49f7-a537-2bce90817e9e / ext4 rw,noatime,discard,data=ordered 0 1
UUID=df5f3cab-1647-4ce8-a725-13b92b664476 /home xfs rw,noatime,attr2,discard,inode64,noquota 0 2
Comment by Antonio Rojas (arojas) - Monday, 30 January 2017, 21:53 GMT
Can you please try:

cp /bin/uname ~/.cache/ && ~/.cache/uname
Comment by Simon (Giggi) - Tuesday, 31 January 2017, 07:22 GMT
> cp /bin/uname ~/.cache/ && ~/.cache/uname
> bash: /home/sim/.cache/uname: Permission denied

Same result also if I a try with "sudo"


Comment by Simon (Giggi) - Tuesday, 31 January 2017, 07:56 GMT
Another note:
Before the crash of the login procedure it appear the mouse pointer (icon) that normally I use with KDE.

I'm using an Nvidia video-card with the related driver (nvidia)

In the /var/log/Xorg.0.log I've seen this suspect message ....

[ 1660.705] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 1660.705] (II) NVIDIA(0): may not be running or the "AcpidSocketPath" X
[ 1660.705] (II) NVIDIA(0): configuration option may not be set correctly. When the
[ 1660.705] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[ 1660.705] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[ 1660.705] (II) NVIDIA(0): details, please see the "ConnectToAcpid" and
[ 1660.705] (II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
[ 1660.705] (II) NVIDIA(0): Config Options in the README.
[ 1660.717] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
Comment by Antonio Rojas (arojas) - Tuesday, 31 January 2017, 09:12 GMT
> cp /bin/uname ~/.cache/ && ~/.cache/uname
> bash: /home/sim/.cache/uname: Permission denied

Well, there's your problem. Find out why you don't have execute permissions for ~/.cache
As a workaround, set the env variable QML_DISABLE_DISK_CACHE to 1

Loading...