Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52773 - [networkmanager] >= 1.6.0-1 connectifity check reports false positive

Attached to Project: Arch Linux
Opened by Peter Weber (hoschi) - Monday, 30 January 2017, 10:10 GMT
Last edited by Jan Alexander Steffens (heftig) - Sunday, 19 June 2022, 09:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Hello!
Looks like the new PKGBUILD contains an automatic connection-check and if it fails, it will add a 'question mark' about the connection icon in the System-Tray of GNOME. I'm here in a company with a regular (forward) proxy, which is configured for http, https and ftp inside NetworkManager. The internet connection works fine and I can access the URI 'http://pkgbuild.com/check_network_status.txt', so this is a false positive.

Additional info:
* package version(s): >= 1.6.0-1
* config and/or log files etc.:
Jan 30 11:04:06 lap-lnx-pew NetworkManager[377]: <info> [1485770646.4526] connectivity: check for uri 'http://pkgbuild.com/check_network_status.txt' failed with 'Could not connect: Network is unreachable'


Steps to reproduce:
1. upgrade to 1.6.0-1 or above
2. network behind a proxy e.g. squid + mcafee (in my case)
3. watch the top right corner of GNOME3 after the network is up (usually at login prompt or after login)

Thanks
PS: I've applied the file mode change for "install -dm700 "$pkgdir/etc/NetworkManager/system-connections", but that shouldn't be the problem, because everything works.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Sunday, 19 June 2022, 09:53 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Intended behavior of connectivity checking. Disable it if this bothers you.
Comment by Jan Alexander Steffens (heftig) - Friday, 03 February 2017, 18:03 GMT
I'm not sure if the connectivity check can use a proxy. You can disable it by placing an empty file at /etc/NetworkManager/conf.d/20-connectivity.conf
Comment by Devin Williams (twofive0) - Monday, 21 August 2017, 14:15 GMT
A work-around for this is to disable connectivity checking altogether if it bugs you too much (as it does me!) Of course, network connectivity won't be checked at all so this will make NetworkManager always report internet connectivity as true.

Edit /etc/NetworkManager/NetworkManager.conf

add/edit the lines:

[connectivity]
interval=0

save the file then restart NetworkManager
Comment by Eli Schwartz (eschwartz) - Monday, 21 August 2017, 17:01 GMT
@twofive0,

Power-posting isn't particularly useful here. heftig *already* suggested disabling the check, and in a manner that is more appropriate.
You really should use/disable conf.d dropins rather than the main configuration file, as they are far easier to add and remove.

Meanwhile, if you just want to indicate that you are affected by this bug then you can simply vote for it...
Comment by Jan Alexander Steffens (heftig) - Monday, 21 August 2017, 17:18 GMT
There is currently also a bug in curl that makes the check almost always fail. This is fixed in curl 7.55.1-2.
Comment by Devin Williams (twofive0) - Tuesday, 22 August 2017, 13:48 GMT
@eschwartz

I'm not sure what a power-post is, but I didn't mean to offend anyone. Please accept my humble apology. Admittedly, I skimmed the first comment and didn't recognize it as the work-around. I thought I was being helpful.
Comment by mattia (nTia89) - Friday, 25 February 2022, 16:10 GMT
Is this issue still valid with latest version of networkmanager?
Comment by Peter Weber (hoschi) - Saturday, 21 May 2022, 10:38 GMT
Yes. And no.
Proxies break TCP/IP networking present undefined behavior. NetworkManager checks if a direct connection is possible:
https://bugzilla.gnome.org/show_bug.cgi?id=738694#c14

And therefore it reports if a direct connection is not possible. Probably opinions differ here but I accept it.
Upstream marked the issue as "RESOLVED OBSOLET" and our wiki explains how to turn off the connectivity check:
https://wiki.archlinux.org/title/NetworkManager#Checking_connectivity

I will ask for closing this bug.

Loading...