Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52772 - dropping i686 support and systems with 32-bit EFI

Attached to Project: Arch Linux
Opened by Ingo Albrecht (indigo) - Monday, 30 January 2017, 10:08 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 31 January 2017, 04:26 GMT
Task Type Support Request
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

There are 64-bit capable systems which require 32-bit .efi to boot (limitation of efi implementations). Some examples are described in [1], but these cornercases likely are more widespread.

Has it been decided how support with the bootloader packages for these boxes is going to be after i686 support is dropped?

(first example that springs to mind is systemd-bootia32.efi. Please assign to a bootloader package maintainer & djgera for the ISO)

[1] https://wiki.archlinux.org/index.php/Unified_Extensible_Firmware_Interface#UEFI_Firmware_bitness
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 31 January 2017, 04:26 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Monday, 30 January 2017, 15:45 GMT
The ISO doesn't support this right now, and there's no way to use a boot menu like systemd-boot for loading a 64-bit kernel on 32-bit UEFI anyway. They would only affect GRUB and possibly SYSLINUX.
Comment by Ingo Albrecht (indigo) - Monday, 30 January 2017, 17:59 GMT
Ok, I was unaware the ISO does not support it.

A search indicates affected users work-around by either:
- the archboot ISO (/package), e.g. https://bbs.archlinux.org/viewtopic.php?pid=1672148#p1672148
- boot/install in legacy BIOS and generate the 32-bit efi manually later.

It also shows boxes with Intel Baytrail (i.e. laptops from last year) appear to have such UEFI limitation frequently.
Comment by Doug Newgard (Scimmia) - Monday, 30 January 2017, 18:12 GMT
I see nothing in either the grub or syslinux packages that should be a problem here. Going to close this unless there's an actual issue.

Edit: I didn't see your post until after I replied. The main workaround is to modify the ISO to use GRUB for 32-bit UEFI with the instructions in the wiki. This should still work fine after i686 is gone, as I said.

Loading...