Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52768 - [mkinitcpio] Fails to assemble FakeRAID array because EFI vars are not mounted

Attached to Project: Arch Linux
Opened by Jurica Vukadin (u-ra) - Sunday, 29 January 2017, 23:40 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 11 March 2017, 17:16 GMT
Task Type Bug Report
Category Arch Projects
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I have two SSDs in an Intel RST FakeRAID booting in UEFI mode.
The entire system (/ + /boot + /home) is on the array. mdadm_udev hook is enabled.

mdadm cannot assemble the array because it needs to read /sys/firmware/efi/efivars/RstSataV-<GUID>
to get the info on the controller and the array.

I have worked around the issue by adding 'mount -t efivarfs none /sys/firmware/efi/efivars'
to /usr/lib/initcpio/init and IgnorePkg'ing mkinitcpio.

mkinitcpio 22-1
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 11 March 2017, 17:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  https://git.archlinux.org/mkinitcpio.git /commit/?id=70511e5ccb7e2500213e04173a70 c067a7c9aa35
Comment by Dave Reisner (falconindy) - Friday, 10 March 2017, 12:11 GMT
Have you tried using the systemd hook instead of base? This should mount the efivars FS for you.
Comment by Jurica Vukadin (u-ra) - Friday, 10 March 2017, 22:17 GMT
Okay, it works. I had to change root=PARTUUID=... to root=/dev/md126p2 in kernel cmdline, or systemd hook would time out.
Thank you.

Loading...