Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#52581 - add support for squashfs root bigger than 4G

Attached to Project: Release Engineering
Opened by Kieran Colford (kieranc) - Monday, 16 January 2017, 18:09 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Friday, 23 February 2018, 03:09 GMT
Task Type Feature Request
Category ArchISO
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Although the ISO file format can handle squashfs images bigger than 4G, you cannot extract it to a FAT32 file system as is described in https://wiki.archlinux.org/index.php/USB_flash_installation_media#In_GNU.2FLinux_2

While this isn't necessarily relevant to the official Arch ISO, some downstreams (like blackarch) suffer from this. Rather than filing a report there it made more sense to upstream the issue.

Could you use dmsetup or mdadm to place the squashfs image on a linear RAID array of image files? And can you also add support to the mkinitcpio hooks for this?
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Friday, 23 February 2018, 03:09 GMT
Reason for closing:  Won't implement
Additional comments about closing:  use a better filesystem
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 18 January 2017, 04:08 GMT
looks like title is wrong. squashfs can grow beyond 4G, the issue is the fs layer that contain such image, in this use a more advanced than FAT fs, ntfs, ext4, etc...
Sure if things does not get complex patches are welcomed.

Loading...