Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52528 - [libxml2] libxml2 python module is broken for python 3.6

Attached to Project: Arch Linux
Opened by Abdó Roig-Maranges (abdo) - Friday, 13 January 2017, 09:49 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 24 January 2017, 12:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

libxml2 python module fails to load in python 3.6 due to missing _PyVerify_fd symbol.


Additional info:
* python 3.6.0-1
* libxml2 2.9.4+12+ge905f081-4


Steps to reproduce:

Python 3.6.0 (default, Dec 24 2016, 08:03:08)
[GCC 6.2.1 20160830] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import libxml2
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/usr/lib/python3.6/site-packages/libxml2.py", line 1, in <module>
import libxml2mod
ImportError: /usr/lib/python3.6/site-packages/libxml2mod.so: undefined symbol: _PyVerify_fd

Additional comments:

This is known to upstream https://bugzilla.gnome.org/show_bug.cgi?id=776815 but no patch is available. Looking at the source, _PyVerify_fd appears in just one place, and Fedora happily removes it http://pkgs.fedoraproject.org/cgit/rpms/libxml2.git/tree/libxml2-2.9.4-remove-pyverify_fd.patch. I'm not sure what would be a proper fix though.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 24 January 2017, 12:54 GMT
Reason for closing:  Fixed

Loading...