Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52503 - [linux] no keyboard input on macbookpro with 4.9.2

Attached to Project: Arch Linux
Opened by Gaetan Bisson (vesath) - Thursday, 12 January 2017, 02:02 GMT
Last edited by Gaetan Bisson (vesath) - Tuesday, 17 January 2017, 01:40 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity High
Priority Urgent
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On my MacBook Pro 12,1 (A1502) linux-4.9.2 fails to allocate usb_device. In particular, the keyboard is ignored so I am unable to login or do anything with my laptop.

On linux-4.8.13 the situation is somewhat better: it takes a while for the kernel to allocate usb_device but it succeeds eventually. So I can login after about thirty seconds. (Much better late than never!)

From the kernel ring buffer it looks like xhci_hcd dying has something to do with this...
This task depends upon

Closed by  Gaetan Bisson (vesath)
Tuesday, 17 January 2017, 01:40 GMT
Reason for closing:  Fixed
Comment by Julian Xhokaxhiu (JulianXhokaxhiu) - Saturday, 14 January 2017, 12:38 GMT
Did you try with 4.9.3?
Comment by Gaetan Bisson (vesath) - Saturday, 14 January 2017, 21:40 GMT
Wow, 4.9.3 actually does fix this isuee. Cheers!
Comment by Gaetan Bisson (vesath) - Tuesday, 17 January 2017, 00:03 GMT
So 4.9.3 worked like a charm but 4.9.4 has the regression again.
Comment by Gaetan Bisson (vesath) - Tuesday, 17 January 2017, 01:40 GMT
There seems to be a race condition somewhere because I cannot deterministically reproduce this with 4.9.4. I'll close this bug report until I have something more precise to report.

Loading...