Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52476 - harfbuzz undefined symbol: FT_Get_Var_Blend_Coordinates after updae

Attached to Project: Arch Linux
Opened by Eric Blau (eblau) - Tuesday, 10 January 2017, 16:42 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 10 January 2017, 17:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I have been having various problems with programs like VirtualBox not starting after updating to harfbuzz and harfbuzz-icu 1.4.1-1 yesterday (2017-01-09). The VirtualBox GUI fails to start with the following error:

VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/libharfbuzz.so.0: undefined symbol: FT_Get_Var_Blend_Coordinates

I've seen the same undefined symbol in the pacman post-install hook as well with the same symbol. Using version 1.3.4-1 of harfbuzz and harfbuzz-icu works fine. I downgraded to temporarily get around this problem.

Steps to reproduce:

Do a full system upgrade to install harfbuzz 1.4.1-1.
Try to start the virtualbox GUI.
Observe the undefined symbol error.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 10 January 2017, 17:05 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Unsupported freetype2 packages are unsupported.

Loading...