Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52434 - [deluge] [harfbuzz] deluge-gtk does not load anymore

Attached to Project: Arch Linux
Opened by John (graysky) - Sunday, 08 January 2017, 10:21 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 08 January 2017, 10:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Upon updating, deluge-gtk throws errors and does not launch:

% deluge-gtk
Traceback (most recent call last):
File "/usr/bin/deluge-gtk", line 11, in <module>
load_entry_point('deluge==1.3.13', 'gui_scripts', 'deluge-gtk')()
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 561, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2631, in load_entry_point
return ep.load()
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2291, in load
return self.resolve()
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2297, in resolve
module = __import__(self.module_name, fromlist=['__name__'], level=0)
File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/__init__.py", line 1, in <module>
from gtkui import start
File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/gtkui.py", line 50, in <module>
reactor = gtk2reactor.install()
File "/usr/lib/python2.7/site-packages/twisted/internet/gtk2reactor.py", line 99, in install
reactor = Gtk2Reactor(useGtk)
File "/usr/lib/python2.7/site-packages/twisted/internet/gtk2reactor.py", line 71, in __init__
import gtk as _gtk
File "/usr/lib/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 40, in <module>
from gtk import _gtk
ImportError: /usr/lib/libharfbuzz.so.0: undefined symbol: FT_Get_Var_Blend_Coordinates


Additional info:
* package version(s)
* config and/or log files etc.

* deluge 1.3.13+11+g48cedf635-1
* harfbuzz 1.4.1-1

Steps to reproduce:
1) Install deluge package
2) From a shell: deluge-gtk
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 08 January 2017, 10:29 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Using unsupported freetype
Comment by John (graysky) - Sunday, 08 January 2017, 10:24 GMT
It seems that this bug is due not at deluge but to harfbuzz; downgrading to harfbuzz-1.3.4-1 allows deluge-1.3.13+11+g48cedf635-1 to operate just fine.

Loading...