Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52424 - Harfbuzz update breaks Nvidia proprietary driver

Attached to Project: Arch Linux
Opened by Sean Lingham (Cxpher) - Saturday, 07 January 2017, 21:08 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 07 January 2017, 21:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Upgrading harfbuzz and harfbuzz-icu from 1.3.4-1 to 1.4.1-1 breaks the NVIDIA proprietary driver and as a result, anything else that's configured to use it (eg. VLC using VDPAU).

Additional info:
* package version(s)
harfbuzz* 1.4.1-1
* config and/or log files etc.

Steps to reproduce:

1. With a NVIDIA card, install latest proprietary drivers from NVIDIA from Arch main repo
2. Upgrade harfbuzz and harfbuzz-icu from 1.3.4-1 to 1.4.1-1
3. Restart X or reboot machine
4. Nvidia-settings panel and anything depending on nvidia-settings or nvidia-smi will no longer function

Simply rollback to 1.3.4-1 for harfbuzz-* and restart X or reboot machine to fix issue.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 07 January 2017, 21:32 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Update your broken freetype2
Comment by Doug Newgard (Scimmia) - Saturday, 07 January 2017, 21:19 GMT
What's the actual error in the terminal?
Comment by Sean Lingham (Cxpher) - Saturday, 07 January 2017, 21:30 GMT
ERROR: /usr/lib/libharfbuzz.so.0: undefined symbol:
FT_Get_Var_Blend_Coordinates
libnvidia-gtk3.so: cannot open shared object file: No such file or
directory
libnvidia-gtk2.so.375.26: cannot open shared object file: No such file
or directory
libnvidia-gtk2.so: cannot open shared object file: No such file or
directory


ERROR: A problem occured when loading the GUI library. Please check your
installation and library path. You may need to specify this library when
calling nvidia-settings. Please run `nvidia-settings --help` for usage
information.
Comment by Sean Lingham (Cxpher) - Saturday, 07 January 2017, 21:31 GMT
You don't even need to restart X when you downgrade. The moment you downgrade, it's back to normal.

Loading...