Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#52406 - [uwsgi-plugin-php] php plugin segfaults

Attached to Project: Community Packages
Opened by Damjan Georgievski (damjan) - Friday, 06 January 2017, 21:04 GMT
Last edited by Felix Yan (felixonmars) - Wednesday, 18 January 2017, 01:58 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Pierre Schmitz (Pierre)
Sven-Hendrik Haase (Svenstaro)
Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No


running uwsgi with the php plugin segfaults.

wild guess, was it built against the php-7.1 in testing? php-7.1 introduced api/abi incompatibilities that are not yet supported in uwsgi

Name : uwsgi-plugin-php
Version : 2.0.14-2

$ uwsgi --plugin php -s :0
*** Starting uWSGI 2.0.14 (64bit) on [Fri Jan 6 22:00:34 2017] ***
compiled with version: 6.2.1 20160830 on 26 December 2016 01:49:45
os: Linux-4.8.13-1-ARCH #1 SMP PREEMPT Fri Dec 9 07:24:34 CET 2016
nodename: archaeopteryx
machine: x86_64
clock source: unix
pcre jit disabled
detected number of CPU cores: 4
current working directory: /home/damjan/src/uwsgi
detected binary path: /usr/bin/uwsgi
*** WARNING: you are running uWSGI without its master process manager ***
your processes number limit is 31108
your memory page size is 4096 bytes
detected max file descriptor number: 1024
lock engine: pthread robust mutexes
thunder lock: disabled (you can enable it with --thunder-lock)
uwsgi socket 0 bound to TCP address :40595 (port auto-assigned) fd 3
!!! uWSGI process 2027 got Segmentation Fault !!!
*** backtrace of 2027 ***
uwsgi(uwsgi_backtrace+0x2c) [0x466eec]
uwsgi(uwsgi_segfault+0x21) [0x4672b1]
/usr/lib/ [0x7fb7647f70b0]
/usr/lib/uwsgi/ [0x7fb7636353ca]
*** end of backtrace ***
This task depends upon

Closed by  Felix Yan (felixonmars)
Wednesday, 18 January 2017, 01:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.0.14-6/-7
Comment by George Brooke (GeorgeB) - Saturday, 07 January 2017, 20:53 GMT
Confirming that this is fixed by rebuilding uwsgi from ABS on a system without [testing] enabled.
Comment by Sven Nguyen Van (snv) - Sunday, 08 January 2017, 18:01 GMT
Worked for me too. Thanks a lot.
Comment by Sven-Hendrik Haase (Svenstaro) - Monday, 09 January 2017, 23:53 GMT
@pierre what should I do with this? I can rebuild for now but I'm not sure what to do about php 7.1.
Comment by Damjan Georgievski (damjan) - Monday, 09 January 2017, 23:57 GMT
I hope 2.0.15 will have a fix for this issue, but I'm surprised (and appalled) that more extensions don't have problems with php 7.1
Comment by Damjan Georgievski (damjan) - Wednesday, 11 January 2017, 01:07 GMT
uwsgi package 2.0.14-4 fixed it, 2.0.14-5 broke it again.

Comment by Felix Yan (felixonmars) - Tuesday, 17 January 2017, 16:37 GMT
I've rebuilt it again with [extra]/php in -6, and added a patch for PHP 7.1 in -7. Please let me know if it works for you.
Comment by Damjan Georgievski (damjan) - Tuesday, 17 January 2017, 16:42 GMT
2.0.14-6 works fine

I was told that 2.0.15 is to be released soon, with php 7.1 supported.

PHP 7.0 and 7.1 are still not ABI compatible, so uwsgi will have to be compiled against the proper version in extra/
Comment by Damjan Georgievski (damjan) - Wednesday, 18 January 2017, 00:44 GMT
and FYI,
php-7.1.1RC1-1 and uwsgi-plugin-php-2.0.14-7 work fine too.
Comment by Felix Yan (felixonmars) - Wednesday, 18 January 2017, 01:58 GMT