Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52402 - [opam] libpythong3.5m.so.1.0 now libpython3.6m.so.1.0

Attached to Project: Community Packages
Opened by TJ Griffiths (teejer) - Friday, 06 January 2017, 16:50 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 06 January 2017, 18:07 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I flagged this package out of date, but maybe that was the wrong approach. So I'm filling this out now as well.

After running pacman -Syu this morning and upgrading a long of pythong stuff I am getting the error below. It looks like libpythong3.5.so.1.0 has been upgraded to libpython3.6m.so.1.0


=-=- Updating package repositories =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
[default] synchronized from https://opam.ocaml.org
[WARNING] External solver failed:
# opam-version 1.2.2
# os linux
# command aspcud /home/user/.opam/log/solver-in-3444-58c514 /home/user/.opam/log/solver-out-3444-ffb3fd -count(down),-count(removed),-notuptodate(solution),-sum(solution,version-lag),-count(new)
# path /home/user
# exit-code 1
# env-file /home/user/.opam/log/log-3444-05296d.env
# stdout-file /home/user/.opam/log/log-3444-05296d.out
# stderr-file /home/user/.opam/log/log-3444-05296d.err
### stderr ###
# gringo: error while loading shared libraries: libpython3.5m.so.1.0: cannot open shared object file: No such file or directory
# error: gringo returned with non-zero exit status

[ERROR] External solver failure, please fix your installation and check
/home/user/.opam/config and variable $OPAMEXTERNALSOLVER.
You may also retry with option --use-internal-solver
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 06 January 2017, 18:07 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Friday, 06 January 2017, 17:20 GMT
The version of "gringo" in the repos links to python2. Is this something you've installed outside of pacman?
Comment by TJ Griffiths (teejer) - Friday, 06 January 2017, 18:00 GMT
That looks like that did it. I installed gringo from aur instead of clingo from the repos. Switched to clingo. Sorry about that. Thanks for the help.

Loading...