Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52377 - [arduino] Version 1.8.0 breaks compilation of Arduino sketches

Attached to Project: Community Packages
Opened by Glen D'souza (gdsouza) - Thursday, 05 January 2017, 16:55 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 08 January 2017, 06:14 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To NicoHood (NicoHood)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Arduino 1.8.0-2 will fail to compile sketches, due to a missing '-tools' parameter,
which is to be passed from the IDE to arduino-builder


Additional info:
Package version = 1:1.8.0-2


Steps to reproduce:
* Open arduino IDE
* Load any example sketch
* Click 'Verify/Compile'


Steps to fix:
* Create directory /usr/share/arduino/tools-builder
This works, due to the IDE adding a -tools parameter to the call to arduino-builder, if the aforementioned directory exists.


Failure log:
/usr/share/arduino/arduino-builder -dump-prefs -logger=machine -hardware /usr/share/arduino/hardware -built-in-libraries /usr/share/arduino/libraries -libraries /home/glen/Arduino/libraries -fqbn=archlinux-arduino:avr:nano:cpu=atmega328 -ide-version=10800 -build-path /tmp/arduino_build_7683 -warnings=none -prefs=build.warn_data_percentage=75 -verbose /usr/share/arduino/examples/01.Basics/Blink/Blink.ino
Parameter 'tools' is mandatory
Usage of /usr/share/arduino/arduino-builder:
-build-options-file string
Instead of specifying --hardware, --tools etc every time, you can load all such options from a file
-build-path string
build path
-built-in-libraries value
Specify a built-in 'libraries' folder. These are low priority libraries. Can be added multiple times for specifying multiple built-in 'libraries' folders
-compile
compiles the given sketch
-core-api-version string
version of core APIs (used to populate ARDUINO #define) (default "10600")
-debug-level int
Turns on debugging messages. The higher, the chattier (default 5)
-dump-prefs
dumps build properties used when compiling
-fqbn string
fully qualified board name
-hardware value
Specify a 'hardware' folder. Can be added multiple times for specifying multiple 'hardware' folders
-ide-version string
[deprecated] use 'core-api-version' instead (default "10600")
-libraries value
Specify a 'libraries' folder. Can be added multiple times for specifying multiple 'libraries' folders
-logger string
Sets type of logger. Available values are 'human', 'machine' (default "human")
-prefs value
Specify a custom preference. Can be added multiple times for specifying multiple custom preferences
-preprocess
preprocess the given sketch
-quiet
if 'true' doesn't print any warnings or progress or whatever
-tools value
Specify a 'tools' folder. Can be added multiple times for specifying multiple 'tools' folders
-verbose
if 'true' prints lots of stuff
-version
prints version and exits
-vid-pid string
specify to use vid/pid specific build properties, as defined in boards.txt
-warnings string
Sets warnings level. Available values are 'none', 'default', 'more' and 'all'

Error compiling for board Arduino Nano.

This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 08 January 2017, 06:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  arduino 1:1.8.0-3
Comment by NicoHood (NicoHood) - Saturday, 07 January 2017, 10:39 GMT
This works for me, as it finds a tools folder in my local ~/.arduino folder:
/usr/share/arduino/arduino-builder -dump-prefs -logger=machine -hardware /usr/share/arduino/hardware -hardware /home/arch/.arduino15/packages -hardware /home/arch/hackallthethings/sketchbook/hardware -tools /home/arch/.arduino15/packages -built-in-libraries /usr/share/arduino/libraries -libraries /home/arch/hackallthethings/sketchbook/libraries -fqbn=archlinux-arduino:avr:nano:cpu=atmega328 -ide-version=10800 -build-path /tmp/arduino_build_348291 -warnings=all -prefs=build.warn_data_percentage=75 -verbose /usr/share/arduino/examples/01.Basics/Blink/Blink.ino

(Highlight of the line:)
-tools /home/arch/.arduino15/packages

I am going to add an empty folder then. Please test the version in testing which I will upload in a few minutes.
Comment by NicoHood (NicoHood) - Saturday, 07 January 2017, 14:02 GMT Comment by Glen D'souza (gdsouza) - Sunday, 08 January 2017, 03:57 GMT
Testing package (1:1.8.0-3) fixes it.

Loading...