Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52376 - [linux] System frozen soon after boot completed (4.9 only)

Attached to Project: Arch Linux
Opened by Chih-Hsuan Yen (yan12125) - Thursday, 05 January 2017, 09:45 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 11 January 2017, 06:10 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After upgrading kernel from 4.8.13 to 4.9, my laptop randomly gets frozen. The time is about 1~2 minutes after boot completed. Downgrading to 4.8.13 and everything is fine. Unlike  FS#52246 , I can login before the system gets frozen.

`dmesg` output is attached.

Approaches tried:

1. In dmesg log,
[ 245.404952] INFO: task systemd-hostnam:405 blocked for more than 120 seconds.
[ 245.405014] Not tainted 4.9.0-1-ARCH #1
[ 245.405044] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

So I `sudo mv /usr/lib/systemd/systemd-hostnamed{,.backup}`. After reboot system freezing is still. I guess systemd-hostnamed is also a victim rather than the cause

2. According to https://bbs.archlinux.org/viewtopic.php?id=134249, tried to disable IPv6. Still freezing

Additional info:

Software:
testing/linux 4.9-1
core/systemd 232-6
testing/linux-firmware 20161222.4b9559f-2
extra/zsh 5.3.1-1

Hardware
Laptop: Acer Aspire E1-571G
CPU: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz

Steps to reproduce:
1. Install testing/linux 4.9
2. Login to tty1
3. Play with some simple commands, ls, htop, vim, etc.
4. System gets frozen
   log.txt (58.3 KiB)
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 11 January 2017, 06:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.9.1-1
Comment by Chih-Hsuan Yen (yan12125) - Tuesday, 10 January 2017, 18:51 GMT
I've using 4.9.1 for several days and apparently the kernel bug has already been fixed. This issue may be closed.

Loading...