Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52367 - [lib32-libcurl-gnutls] Conflict with lib32-curl

Attached to Project: Community Packages
Opened by Fabian (Tids) - Wednesday, 04 January 2017, 17:51 GMT
Last edited by Maxime Gauduin (Alucryd) - Sunday, 29 January 2017, 22:03 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

right now you can not install lib32-libcurl-gnutls and lib32-curl at the same time because of

error: failed to commit transaction (conflicting files)
lib32-curl: /usr/lib32/libcurl.so.4 exists in filesystem

file /usr/lib32/libcurl.so.4
/usr/lib32/libcurl.so.4: symbolic link to libcurl-gnutls.so.4.4.0
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Sunday, 29 January 2017, 22:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  7.52.1-2
Comment by Capitani Stefano (Ste74) - Sunday, 22 January 2017, 00:34 GMT
  • Field changed: Percent Complete (100% → 0%)
If you install lib32-libcurl-gnutls before and try to install lib32-libcurl you can't because already exist libcurl.so.4 . I don't know why lib32-libcurl-gnutls do this symlink because i can't see in th pkgbuild this .. Try it ..

https://github.com/manjaro/packages-community/pull/252#issuecomment-274267132

If here is the wrong place please point me where ..

Greetings Stefano
Comment by Doug Newgard (Scimmia) - Sunday, 22 January 2017, 00:34 GMT
OK, so this still has an soname of libcurl.so.4, and when the linker doesn't find a symlink there when ldconfig is run, it creates it. Fun stuff.
Comment by Ramon Buldó (kirek) - Sunday, 22 January 2017, 21:04 GMT
lib32-libcurl-compat has the same problem
Comment by Maxime Gauduin (Alucryd) - Monday, 23 January 2017, 19:03 GMT
Easy fix would be to make both packages depend on lib32-curl.

Loading...